International firmware - update from SD Card (No FlashTools) - for KOSPET Prime 2 updated 2021.06.26

D09-Prime 2 Android 10 firmware – FAW style.

Hi Everyone,
Again, we have something to share with you and we hope you will like it :blush:

Sadly I have to say this now - If this is posted on any other site without using a referring link - we will withdraw this project immediately. This is because we have a partnership with Wiiteer and we respect their trust and support. There are a few sites out there that instead of posting a link to this post - would rather post the Firmware itself - giving no background information about how this project happened. This is not acceptable for our partners or us !

There is also a BETA program now !! See the end of this post for more info

As some of you know – this forum has great support from the solution provider for these watches. We have been working together as friends for many years now. They are called Wiiteer from Shenzhen. They provide us with great firmware support and help us by introducing us to the various brands that you all know.

Over the years we have been listening to all the feedback from you guys for all this time. Things that don’t work and things you would like to see added etc.

Well, we have gained the trust of our friends and they have allowed us to work with them remotely, under license, using their Chinese based environment.
Together, we have produced a unique Android 10 “international” firmware that addresses your problems with the previous default apps.

Wiiteer, @none and I have spent a long time overcoming the remote working challenges to achieve this. If this firmware is well received, then it may be used for other models. If the brands are happy with your feedback. This also means that if any issues are found – they may be corrected to improve the experience.

Here is a great review from our good friend Mr Ticks - please visit and check out his channel :+1:

DISCCLAIMERYou use this firmware by choice.

You accept full responsibility if you damage your device by making a mistake . This will ONLY work on the D09 Prime 2 model. Do NOT try to flash the TWRP from stock on this!!

The Kospet product team know we are posting this and intend to issue it as an OTA – so your feedback is extremely important !!

Test it as much as you can and report ANY issues you find please.

So, stuff that has changed - this includes things like:
Stock Android File Manager – much more functional than the previous one – remember to enable internal storage view by using the 3 dot menu – top right in the app.
Google Calendar,
Google dialler phone app,
Google contacts,
Google messages – including advanced functionality like Wi-Fi calling and instant messaging,
Google assistant – installed as default assistant and now available by long press the back (lower) button.
Full permissions manager and granular control over permissions (please take time to explore these – it is now exactly like an Android 10 mobile phone).

Any other apps that don’t need system permissions can be installed – by choice.

Apps that could not be installed from the play store are now installed without issue.
All previous custom apps are removed.

Task cleaner in the widget section never really worked in Android 10. The task cleaner is in the long press power menu.

To make sure play services app is up to date (after you have signed into Google) you can go to Settings/Apps and Notifications/All apps/Google Play Services and tap on the version details – it will take you to the update page.
All synchronization is working and can be easily controlled.

Then there are some functions added after many member requests:

double tap to wake
Adjustable font size (global)
Nav bar integration allowing “add or edit APNs” in a new square mode.
The layout can still be switched to full screen from the “long press power button menu.”
The Power Menu is now Long Press on an icon – so the restart icon should be press and hold until reboot – for example.
Other subtle features like long press on most of the “quick settings” will take you to the related sub menus now.

Dark mode is fully implemented.

The weather app is working fine and utilizes Google Location Accuracy. The first-time weather is used it will need to obtain location – so GPS can be enabled to achieve this on first run. After this only Wi-Fi is needed because the Location Accuracy function caches your data. If you have not enabled the correct functions for this – you should get a warning to do so.

All dependence on Chinese web services is removed to prevent issues with other locations worldwide.
The WiiWear app is still functional but the ability to disable it along with all the BT broadcast traffic related to that app is now available in the Assistant app.
Apps like Watch Droid are fine and highly recommended.

Possibly one of the most important things to note is that now the firmware is operating more like Android intended – standby battery life can be up to 10 -12 days depending on how you use the device. We get over 8 days even when Wi-Fi is enabled and google is signed in. Of course – this will vary in use cases, but it is a significant improvement.

We worked with Wiitee to make a safer - easier option for you to use this.

You just copy the attached zip file to the watch storage and turn off network.
Then go to Settings, About Watch and choose wireless update.
Then long press power button and choose square screen mode and press the back button.
The Wireless update now shows in square mode.
In the top - right corner, click on the three little dots and choose Local Update.
Choose the zip file you copied across earlier and flash will begin.
It will take a while.
Once complete - please make a full factory reset as this is major update.
That’s it. No need to use flash tools. :grinning:

Important note - you can now update from any version including the previous FAW version

If by some chance you end up in the stock recovery - don’t panic :sweat_smile:
You use the bottom watch button and select “factory reset” followed by press top watch button to confirm your selection. You will be asked again to confirm and then wait for the process to complete.
This rarely happens though.
If you test it and end up in the stock recovery screen - you can factory reset from there and should be fine.
The watch buttons have been re-mapped to allow recovery use and navigation.

If for any reason you end up in a boot loop, you can load stock V1.4 and it will automatically flash during the boot-loop once you connect the cable.

To keep this really simple from now on there will only be two update zips.
V1.0 is for those coming from stock branded firmware
v1.1 and any other further v1.2 etc will be for people who have already used v1.0 and will be an FAW incremental update.
I always say factory reset after an OTA but if you are coming from a previous FAW version it is not 100% needed - but it certainly helps.
However, if you are coming from stock firmware you should definitely factory reset.

Problems with this Firmware? Here is stock v1.4 is available here if needed:

Flash tools if needed:

Please give as much feedback as possible here and we will try to keep up.
Hope you enjoy it.


Again brilliant work :+1: . Its superb :+1:


Finaly…:wink: Thanks to All!:handshake:


I will get on it today! These international firmwares will help cold-starting GPS right? Looks awesome, needed some good news :stuck_out_tongue:

1 Like

I waited for this update, too bad my kospet has been dead for 1 month :disappointed:

hope my replacement prime 2 gets here soon…trackingnr says “handed over to airline” on 11th of april…3 weeks and no more updates… :confused:
hope it turns up soon…

Correct :+1: .

1 Like

Hello ,
Congratulations :+1::+1: Very nice work. :wink::wink: Hopefully one day comes to lem14 too :bangbang::interrobang::thinking::thinking:Best Regards :wink:

1 Like

Since this firmware works better than the stock I hope they release an OTA. I am unfamiliar with flashing and I am afraid of making KP2 unusable. This firmware looks great💪

  1. Trying that play services version control/update. The version info in the bottom of the settings page is grey, and clicking it doesn’t have any visible effect. Long pressing it gives a popup, with the option to copy the version number to the clipboard.

  2. Double clicking screen when black doesn’t turn it on.

Google services update can be found here:


Double tap to wake needs to be enabled here:



Typing an SMS in the new messages app is completely blind in square mode and half blind in round mode.

1 Like

Thanks for the pointer, there should be something doable to fix this on the next version.

1 Like

Thank you for those 2 instructions. Play services updated now and touch to wake enabled. Seems to require 2 touches with a good firm touch - 2 fast short touches are missed, but that’s just a question of getting used to the function.

You can also see the full backspace and shift keys, where I see only half og them.
Do you use the default keyboard, without any tweaks at all ?
(I did a Download flash, followed by factory reset, as instructed, no tweaks of font, keyboard or anything)

It’s standard. Did you change the font size?

after you have written hello to 12345678 without sending, go back to the conversation list then back to the conversation with 12345678. now you should be able to see the text input

the keyboard difference is because of æøå ( I guess)


I answered that already in the post just before yours.