Kospet Prime 2 Official support UPDATED!

I like the Idea too!
Sounds like a “Normal Louncher” in a different Style “Round Style”.
Very good Idea!

1 Like

LEM 10 Startseite
This is my Nova Launcher on Lem10 and why and how i use it. Just fire up my Watch and see every relevant Information i need; double-tapp Screen off.
And thats it! If you @Eric_Crochemore can do something like this for the Prime2; That would be more than nice.

1 Like

How do you guys take screen shots me curious

Hi @6eats ,
i did it with Screeshot_X
I got it from APK Pure.

I use Smart Touch Pro. Because it not only offers a screenshot option but up to 16 others also and presents less of a presence on the screen. It also is still available even in the power save mode so you can turn BT back on to receive messages in power save mode.

No flash tools required now for testing the International firmware - as long as you have not taken the 2.1 OTA.


I like this style

Hi all, any updates on screenshot workarounds? Button mapper doesn’t work for me (says I need to change something in accessibility settings but can’t find said settings) and screenshot pro download link won’t open. Is there no native screenshot option available?

no, there is no native screenshot option. Button mapper should send you to the accessibility settings the first time you open it, so I would just suggest that you uninstall it and install it anew.
you can see how easy it is here: Prime2 2021-05-26 22-49-07.mp4 - Google Drive


Hi, where do I find the triple tap to zoom in the developer settings? I’ve enabled developer settings but don’t see anything like that in the menu.

Hi again, found triple tap zoom under accessibility settings, and button mapper works now too - sort of. I can follow the steps and enable button mapper in accessibility settings, but then after a while it keeps being automatically turned off, so I have to open button mapper again (which doesn’t have an icon, so I have to open it via settings - all applications) and then click OK to go to accessibility settings and re-enable. Any ideas what could be causing it to be switched off?

Slowly getting towards complete smartphone replacement…

A few other things:
-is there a flashlight (or for that matter, a camera flash)? Also in general the picture quality doesn’t seem too good. Any easy adjustments that can be made to improve it?
-anyone else finding that Google Translate doesn’t work? Any hacks/workarounds?
-certain apps seem to disappear quite quickly from the “recent apps” list - Whatsapp is one that I notice the most - anyone know why?
-inconsistency in keyboard and voice input options - in some apps the voice input button appears and in some it doesn’t; in some cases the keyboard pops up with its own input field and then once you’re done you can see what you’ve typed or spoken into the app field full screen, in other cases the keyboard just pops up over the app and you input directly into the field; this is mostly a problem in Google Maps as you can’t see or select the suggestions that appear as you type. In general Google Maps navigation in square screen is too small to be useful.
-the alarm time input doesn’t seem to align properly with the actual time you set.

If anyone has any hacks or workarounds for these, please share!

One more thing - some 3rd party apps (such as Button Mapper and recently Mi Fit) do not create an icon on the app screen after installation and I have to open them via settings - applications. Can I create my own icons for apps? Is it possible to create a “frequently used apps” screen?

Update: @noidremained, I followed those steps in your video and even paid for the pro version (as my only option to map to is the back button) but every time I close the app, after a few minutes the screenshot mapping stops working and I have to go back into the app and follow those steps again. This is obviously a rather tedious way to take a screenshot. Any idea why this could be happening? Seems like the OS is killing the app once I switch out of it.

Hi . No you cannot create your own icons with this launcher . It does sound like the app is going to sleep

In settings make sure the app is " not optimized " and has " unlimited data access " . It then will run in the background

Have you tried the updated FAW international version yet?
You can just drop it on your watch storage and use the Wireless Update app in the “About Watch” section in Settings.

In this version of firmware you can access these settings on every app as the settings are stock Android 10 settings. Like allow to run in the background etc …

1 Like

Wrong thread - feedback in the other thread please

Tried both of of those settings but it still happens. Anything else it could be?

@Benson_Wallace check this out

All recent apps are closing when locking the device - Kospet Products / Kospet Prime 2 - Full Android Watch

Thanks, that seems to have done the trick with button mapper (and I assume it will solve my “apps disappearing from recent apps list” problem too).

Has anyone else tried to install Google Translate?

We have tested it on our version and it is working

1 Like

This is what happens when I try to open it: