Prime 2 not powering on

Hello fellas I have a bit of a concern. I recently went without wearing my P2 for a couple of days for the first time since January. Unfortunately my battery died during that time. I’m saying all of that to say this, I put my P2 on the charger for an hour for a full charge when I tried to power on I got nothing but the more baffling part is that when I reconnected the charger I got the kospet screen then a screen that says 100% battery then nothing.

Anybody have an idea of what’s going on? Please and thank you for your assistance fellas.

I had exactly the same issue . The one way to get this to work is to completely drain the battery until it will not even boot up for any more ( i know it will take ages ) . Then you need to flash the firmware before it reboots once connected to charger .

I see what your saying but here’s the thing. It started on a fully depleted battery so I don’t think that should be necessary but I’ll try it but how would I even know the battery is full or not if it isn’t powering on at all? Also I don’t know how to flash and not to sound lazy but I’m not tech savvy enough to not jack something up.

Okay . So if you comnect to pc and your watch doesnt start you are okay to flash .

Here is a general tutorial . Read carefully and keep calm . Make sure you select firmware upgrade in flash tool .

Here are the tools you need on your Pc

And you will need this firmware

Make sure you use version 1.4 ( not the others )

And problems let me know :+1:


Alright fellas, unfortunately I’m away from PC for the next two days but I will definitely give this a shot. As always I truly appreciate you guys effort in assisting poor saps like myself with these issues. As soon as I am able to try this method I will update immediately. Thanks again.

1 Like

Have you tried long press the power button and force a reboot? Sometimes it can be done and helps.
Flashing the firmware resets a few things and sometimes can help in this situation as @Dr_Andy_Vishnu says.
It is definitely worth trying.
Which version of firmware were you using before the problem?
Was it v2.1…? That was the latest OTA version from Kospet.

I absolutely tried to long press the power button, that was my first go to move for sure but unfortunately nothing. That’s what’s so weird about it, the fact that I got the kospet screen when I attached the charger then a screen saying it was fully charged but it was not the usual charging screen with the green bar that circles as it charges. After that screen goes away which last literally two seconds then it goes off.

I’m using the 2.1 version I believe because I do remember updating in May I believe it was (not certain when that update came through) but I updated, restarted and I noticed a lot of the changes but I stopped there. I never rooted or flashed anything like I was reading about in the update threads because that type of thing was just out of my league.

You need to flash the stock firmware.
It sounds like a problem with the launcher failing to start.
Therefore black screen.
Just flash the firmware from your pc.
Must be a Windows PC or laptop