The Kospet PRIME Official post

Reinstall the drivers.
It seems that the vcom port is not operating when you connect to the watch.
If you are flashing twrp and patched boot you should remove the checksum generator exe and file, because obviously the different images are not the same as the original images so chesksum is broken.

thanks, I’ll try that, but had regen’d the Checksum.ini file and wasnt getting crc errors (tell me Im wrong). But definitely seems like vcom is the culprit - all the flash logs Ive looked at end with the same line… Have also found the linux tools at spflashtool.com but they’re qt4 based and Ive just purged that to work on qt5 for another project so I’ll thank you all again for your help and go away to solve that headache. In the meantime, I have factory reset the watch anyway and have working clockface directory and install and my deteriorating bluetooth issues (I never mentioned them! bluetooth sucks, always) have cleared up too.

For those interested, here’s a step-by-step “happy path” for root and flash of your Prime.

1. Download flash tool and firmware 2_3B
2. Download v1.5 also to get twrp recovery
3. unzip the v1.5 firmware on your PC
4. unzip your new firmware on your PC, e.g. v2_3B
5. copy “recovery_twrp.img” file from the img subdir of v1.5 into the v2.3b img folder. Rename as recovery.img (move the original to another location or rename it to something else beforehand)
6. if you also notice that there is no existing “magisk_patched.img” file in the unzipped firmware/img folder– you will have to use magisk to patch the boot file. Follow steps 1-8. Otherwise just do step 8.:
    1. install magisk on watch
    2. copy the v2_3b boot.img to watch e.g. to /sdcard/Download
    3. Rename as boot.png so that it will appear in the magisk file selector in 6.5 below*.
    4. Restart phone.
    5. Run magisk and from the two options provided select update magisk (not “update magisk manager app”) and choose “download and patch” image file. 
    6. It will do everything and leave it as “magisk_patched.img” in your phone (/sdcard/Download folder by default)
    7. copy this to your pc from the phone (to the img sub-directory of the place you unzipped the firmware)
    8. rename this file now as boot.img (move the original to another location or rename it to something else beforehand)
7. On your PC, in the unzipped firmware/img directory update checksum.ini with the checksum of your new boot.img file. (or perhaps easier, run checksum_gen.exe in the firmware img folder)
8. Install and Start/run flash tool – 
9. load the scatter file (in the firmware/img folder0. You should get NO errors when you load the scatter file
10. Connect the USB data cable and puck
11. Place the watch on the puck
12. Check the drop down on the top left of the panel says "download". Now click the download button. (should see metadata and yellow progress bar)...)
10. Factory reset.

*Magisk uses an android ContentResolver to build this file list. It works with media filetypes – images, video and audio.

I normally remove the checksum files but must have forgotten that time.

It should NOT be used for anything apart from a straightforward upgrade.
I will not make that mistake again for sure.

Thanks very much for your guide.
My only problem with this is that now there are about 15 guides on here about doing this and the funny thing is that it is the exact same process for all the watches on here…

I might try to consolidate this because people are getting very confused.
We should make a specific section about root and twrp because it is the same for all.
All have same procedure of flashing patched boot and twrp.
But then you have people that flash whole firmware with patched images and people who only flash boot and recovery.

In any of the situations the checksum exe and file should never be in the firmware images folder.

I can only apologise for two things here
a) leaving the checksum files in the firmware
b) not having created a simple one stop reference and tutorial for rooting.

I will get to it but I have just been incredibly busy with so much going on over recent months. In both my personal life and the watch world.

I will fix this asap. :handshake:

3 Likes

well, I dunno.

I ran the USB driver installer again, it seemed to do the same thing as last night, Then came across this post at XDA, and it talked about clicking the download button before inserting the cable and puck, and then placing the watch (off) on the puck. So, I did that, and lo and behold it worked - download commenced, yellow progress bars and success message at the end. So, for now, it seems like I have a rooted watch, twrp and the 2_3b firmware (getting a wireless update message about a new version).

So, alls well that ends well!

Apologies not necessary, everyone busy, but luckily this forum is super helpful and good to see such good community support. You and the regulars gave me confidence to proceed.

Full android watches have a lot of value and its the wearable form factor that suits me. Dont want a big phone, want a tiny one, with an occassional hotspot, notifications, clockfaces with array_type 100 for quick access to things, some music playing, a basic camera, a good battery - and I have a tablet and PC for everything else and a small bluetooth headset so I dont look like im in the CIA when a get a phone call, talking to my wrist :slight_smile:

In case anyone is interested, Ive not succeeded in getting the ubuntu/debian/linux version of flashtool running. Its core dumping with a floating point error. Crash dump not revealing much to me, just that the code seems a little old perhaps.

2 Likes

Pressing the button to get the flash started:

That normally only applies if you have got a stuck bootloader.
Normally happens after a failure to flash.

I flash on Ubuntu as well.
It’s just a couple of lib files you need to update and it works out fine.
Google is your friend

If it was a Zeblaze you would never get it back and 8 months later you will be lucky to get a 75% refund… and that’s only if you kept copies of all shipping tracking advice…they like to stall until the tracking number drops out of the shipping company website…then they pretend not to be able to find any record of your parcel arriving with them.

2 Likes

Good job its not a Zeblaze then . This will certainly not happen to his Kospet . @pablo11 will make sure of that .

3 Likes

Sorry to disagree !!! I have tryed to solve my Kospet Prime, screen issue with no sucess.

You have a screen problem with the Kospet Prime?
The original Prime Android 7.1.1?
That watch has not been made for a long time.
The factory that made it is no longer available.
When and where did you buy it?

I will do my best to help if I can

If you are talking about the Prime SE or the Prime 2 please let me know

Hello Friends, My Kospet Prime 3/32, suddenly keep restarting itself automatically and does not go forward Kospet Boot Screen and keeps restarting, now even battery has died and when I plug in the charger it keeps doing the same thing. What could be the issue? I have a video but I cannot upload since I am a new user here.

Flashing the firmware is probably the best option . Which Prime are you using ?

What did you do just before this issue happened ? Did you install a app or clockskin

Thanks

Thanks Vishnu, I have Kospet Prime 3GB/32B (First ever model), Clockskin was installed for more than a year but this issue happened suddenly few days back. I did not install any app recently.

I have tried to flash the firmware but watch is not recognised by the USB port since the watch is continuously rebooting when plugged on charger.

No problem . I have had this issue before . The only way is to kill the battery ( run it dry over and over by rebooting ) until the screen wont come on . You then will have just enough time to flash

1 Like

@Dr_Andy_Vishnu is right. Please use the “firmware upgrade” option instead of “download only” in this case.

1 Like

Thank you @Dr_Andy_Vishnu and @G1NT0N1C , I tried flashing twice with both “Firmware Upgrade” and “Download Only” and process was completed, but issue is still same, after flashing it keeps restarting it self, not even charging. I think its related to hardware and not software.

Thanks much for your time and help. :raised_hands: :pray: :handshake: :+1:

@nomsonline It sounds like a hardware problem to me.
Have you bumped or knocked the watch recently?

Unfortunately this model was stopped over a year ago so they can’t replace it.

1 Like

Hello @pablo11, I don’t remember any accident like this before it went crazy, but you never know my Toddler could have done it :sweat_smile:

Yes, I think its hardware related.

Cheers and Thanks for the Help guys. :+1:

3 Likes