Watch Droid Phone / Assistant

is android 10…not android 7.1…setting are not in the same place

Yes . Set watchdroid to " dont optimize " and it does work just fine

I am talking about Prime2 android10!

could you please give me step by step direction to your option, because i cannot find it…

sorry, but does not work for me…have set to dont optimize, as soon as the screen turns off, the app disconnects…same with buttonmapper…works perfectly wtih screen on, as soon as the screen has been off, the acces i gave are back to none, and i have to tick them again…



YESSS…you are the man…i was looking under settings…works great now…thanks a milion…


Thank you very much @gyuri a great explanation for many users who have the same problem, with your images it will be much easier to find the options


Hi, I recently received my Kospet Prime 2 and I have it sync’ed with my phone using Droid Watch - awesome piece of software!

I also have Ultimate Launcher installed and I don’t know if the issue I am seeing is related or not but notifications being shown are offset (upper left) and not centered on the watch (see screenshot) - I did some searching and could not find anything yet. I also have no idea where this background image is coming from :slight_smile: I only installed some watch faces for Universal Launcher.

Try to disable the 3rd party app adapter. Normally it is disabled, but you may have enabled it to make a specific app look better…
If that is not the problem, could you have tried to set the DPI setting in UL to a non standard value ?
The background images in the notifications are to make them look more fresh. It you don’t like them, try to change notification settings to high contrast.

1 Like

Thanks for the suggestion! @Dotsfar
I did not set any DPI specific value. I had 3rd Party app adapter setting ON but I turned it off and no change - also restarted Watch. Disabling 3rd party adapter removed the background (now all black) but notifications are still placed at the upper left.
Regarding notifications, could there be conflicts between UL and Droid Watch? Maybe I should uninstall UL and see how notifications behave without it.

I’ve have UL do some weird things if I have the watch in square mode when UL starts. You may want to go to UL setting and restart the launcher

You can try UL with a custom DPI of 180.

1 Like

3 posts were merged into an existing topic: Universal Launcher [Ver. 3.x and above]

i keep getting double notifications on my watch but only from my emails…all the other notifications are single and just fine…i am using outlook…any ideas?

Great to see another big update :+1: . Thankyou


The step counter on my LEM 14 watch seems accurate, but the Step Counter on Watch Droid is wildly wrong. Does the step counter on Watch Droid phone need to be activated for the one on the watch to work? I’ve just de-activated it, so I suppose I’ll find out. My other question, then, is: does the Watch Droid phone app measure steps made by the phone, so to speak, and not relate to the watch at all? Or is it supposed to record the steps counted by the watch? - If so, it doesn’t!
Watch Droid is excellent, by the way, and I’ve just signed up for Premium - with a discount!

On set up of watch droid have you allowed all permissions in watch ?

Sorry, you’ll have to be more specific: are you talking about permissions on the watch droid app on the watch? Or on the phone? And do you mean ALL permissions, or permissions related to steps, GPS, navigation only? I’ve gone through several iterations of giving permissions, rebooting, etc, but can’t get a reasonable figure on the phone app.

I’ll give you an example. Having posted the post above this morning, I disabled step tracker on the droid watch on the phone. The tracker on the watch continued to work and added about 2000 steps from a short walk I had this afternoon. I’ve just enabled the step counter on the droid watch phone app again and it’s added about 9000 steps from when I disabled it earlier, 21k in total today. Yesterday it counted/added 81k steps, 51km! Using Sync Up from the menu dots doesn’t help, makes no changes. I’ve just used the ‘Resync all data’ button on the phone app (without ‘Delete data from the smartwatch already synced’ and that produced the same 21k figure.

I’ll try uninstalling the phone app now, then reinstalling.

Edit: OK, reinstallation has reset the step count to 2,200, which is probably right for the day’s activities. Maybe that’s fixed it! I still don’t know whether it’s reporting steps recorded by the app on the watch, or whether it’s using the phone’s own built-in counter. I’ll have to see how the phone matches with the figures given on the watch.

Yes . I meant permissions in the watch for the watch app

1 Like