Genesis is not charging at all

I got my Genesis smartwatch 1 week before and after 1 day of good working, it stopped working now. Charigin icon is also not displaying at all. After I press and hold power button for around 20 seconds , it is started displaying charging icon, but static image only. It does seem charging the watch. So I can’'t use this watch at now… Need urgent help here. many thanks for your assistance

Hi . Have you pressed and hold BOTH buttons for 20 seconds together ? Try this

When you charge are you using main cable

Hi Mr. Andy,

yes. I tried this trick as well . I kept on press and hold both buttons for about 20 secs. but no luck.

Yes, I am aways using main cable only for charing directly with power outlet. I never used charge station or charge through laptop.

Kindly assist here. Many thanks in advance

1 Like

Maybe try for longer

Also make sure charging cable , pins are clean . Also see if you do get a response once attached to fully charged charging dock


1 Like

This fix applies to those who have been charging and the watch gets warm but will not boot.
Letting it cool down and holding both buttons down for AT LEAST 30 - 50 seconds.
Reports of success have been reported after 30 seconds and above.

As @Dr_Andy_Vishnu says make sure it’s clean but you have a static icon showing and you are not using the dock.
So please try the dock and again as @Dr_Andy_Vishnu said - make sure it is fully charged.

If it is getting warm then let it cool down and try the method of holding down the buttons.

You mentioned a wall socket charger - I would try to use USB socket from a PC as some chargers are putting out “fast charge” which is too much for the watch.

1 Like

Seems mine is not at all charing …guess that is the issue. normally , this icon moves up and down when it really charing. I saw this when I charged this 1st time, after that I never see that…any help

@sisamiakgm So, can you please try a USB port on a laptop or PC before we say it is a bad battery?

If you can get a photo of this watch connected to the PC or laptop by USB cable it will be very helpful. Especially if the red symbol comes on the screen.
Also need to say that if battery has drained completely and utterly empty - that red symbol can remain for up to 10 - 15 minutes before it will start to change and charge.

Charging status can be checked by a very light touch on the top button while connected to the charger or USB port…

And please test the charging dock.
Press the little button on the top and check that the 4 little blue LEDs are on.
If the 4 little LEDs are on, place the watch on the dock and see what happens.

Sorry for all the tests but it is important.

1 Like

thank you for your swift response here . much appreciated. sure. will test all these and post the results shortly . thanks much.

Tried all those ticks mentioned above. none helped me here. but I tried one trick, keep it inside the refrigerator for 15 mins and try charging again, advised by Mr. Jason in PM chat… Many thanks Mr. Jason for your tip. Currently it is charing, I could see blue light flowing up and down. I will check once it is fully charged and keep you posted . thanks once to all of your great and swift responses here.


@sisamiakgm Awesome
Great news …:tada::tada::tada:
That’s why I said that it has to cool down before trying this method…
This is great news :+1::+1::ok_hand:

1 Like

team again it is not a good news. after an hour time, it started booting up and shown the Kronos Blade low. but it stays there for 1 min , after than it shut down by itself. after that again same story … so till now, I could not make my Genesi to run it …need help please… many thanks in advance

That means it needs charging.
Can you place it on the dock and see how much power the battery has please.?
Just like the photo you posted above - but this time plug the cable into the dock and a USB port or regular phone charger

i would try to flash the FW.

1 Like

ok sure will try this and update

Please find the photos . 1) Connected watch to dock. 2) connected dock to MacBook via USB

Bur, I do not see any movement in the charge. so can’t get the charing level ?

Now the charging is moving up…:slight_smile: let me see how it goes this time…


nope. no luck. I guess it has battery issue. though it got charged fully after an hour (shows 100%) , it it is not booting up …It went down immediately after it is on.

need help here what is next step here… thank you

So now you have a 100% charged battery try again pressing and holding two buttons together 30-50 seconds . Thanks

1 Like

Ok Sure. will try this and update.many thanks

1 Like

all, I am tired of trying the same thing again and again. after full charge, it is booting up and stays there on only for few mins. after that same story .

I am very much disappointed about this watch. Waste of money. I was so exited to have this watch. now it is big disappointment.