Watch Droid Phone / Assistant

There is a permission for fitness data on the watch.
Physical activity.
Not sure if this is the problem but thought I would mention it.
This applies to Android 10 at least.

1 Like

Nope, I activated the step counter in watchdroid. It synchronized the steps already in the watch. There are 428 on the watch and it synchronized 60300 :wink:

gaofit says 428. So it’s definitly a problem with the app or a setting that depends to the app.

Thank you for your answer.

Found the permission. Watchdroid is in that permission.

I will Start another test. Perhaps there was a problem with the activity I started. I try it without starting such. Perhaps there is only a problem with this.

Ok.
If that does not work, maybe try to factory reset the watch and start fresh.
I know it sounds silly but you would be amazed at how many times this works.

But hopefully you will not need to :+1:

I tried the factory reset. After this it seemed that it worked correct. Today I started a sports activity again. And during and after that, the step counter in the app goes crazy. There are 28000 steps in the app and 12000 on the watch (12k is correct).
So, it seemes that there is a problem when after you started a sport activity. Anyone with a similar problem? Is there a solution?

There is a version modified by third parties that brings this problem, if you have version 15.16 downloaded from the Play Store, send an email to info.lumaticsoft@gmail.com that you have reviewed your case.

Thank you Pablo11 for your support. It may happen that I have a version modified by third parties that does not work correctly, they have already reported that problem to me and it is solved by downloading the version from Play Store

Yeah, a lot of “cracked” crap out there on the Web as well.
Unfortunately for the general user - they don’t realise that the people who crack it are also injecting malicious code into the app in some cases…

1 Like

It’s the Version 15.16 from the playstore. I’m a software developer, too, so I know if you download cracked stuff, this could be a problem :wink:

So I will write an email to the address you told me. Thank you all for your support. :slightly_smiling_face:

1 Like

its depend on the phone also which phone you are using

Yep, they know this.
They are app devs…

A lot of things change between types of phones and Android versions… :+1:

Can I expect even in future that will be BT calling function?
If they can make it this would be my best app ever used :grin:

No, you can’t expect it.
If anything ever changes you will know all about it.

1 Like

Hi. Awesome app, all functions work fine. The only thing I want to change is the keyboard that is used to reply to messages. Is it possible to replace the default keyboard with a custom one? For example gboard?

I am using version 9.0 and under the notifications options there is a box to ck to use the applications own keyboard. If you have the Gboard as your default keyboard it should work.

2 Likes

Music controller of the watch disconnect recently any1 can explain whi is that happening?
When I reconnect music controller works for some seconds and again unavailable

You have to remove the memory or battery optimization for Watch Droid on your phone
On Xiaomi devices you have to allow the “Automatic start” permission to the notification and music capture service.
To get it working again, you just have to grant Watch Droid the automatic start permission again and re-grant permissions to the notification bar or restart the phone.
This option is found in Settings => Permissions => Autostart
Help image.

Huawei devices have to configure the manual launch of Watch Droid Phone in App Launch.
For this you have to enter Settings => Battery => App launch => Watch Droid Phone => Manage manually
Help image.

Samsung devices not only have battery optimization but also have their own memory optimization settings, check if you have also excluded from there, this is in device care, entering an icon with a chip format, if not is excluded there when the screen is turned off Watch Droid will stop working:

3 Likes