TWRP for Kospet Optimus Pro (KW_C8_LFLT)

Team Win Recovery Project 3.x, or twrp3 for short, is a custom recovery built with ease of use and customization in mind. It’s a fully touch driven user interface no more volume rocker or power buttons to mash. The GUI is also fully XML driven and completely theme-able. You can change just about every aspect of the look and feel.

List of confirmed working devices:
Kospet Optimus Pro

Downloads/Source Code:

TWRP Image Download: 3.2.2-0
TWRP Image Installer Download: 3.2.2-0
TWRP Source Code: Here

Install Instructions:

If you have TWRP installed already:

  1. Download the first link which is just the twrp image files

  2. Copy the image file to your watch

  3. Boot into twrp

  4. Click install

  5. Click install image

  6. Navigate to the twrp image you copied over and select it

  7. Find recovery in the list and select it

  8. Swipe to confirm

  9. You’re done

If you don’t have TWRP installed:

  1. With your watch turned on, copy the file “” to the /sdcard directory.

  2. Turn off your watch.

  3. Open sp flash tool

  4. In the “Scatter-loading File” box choose the “MT6739_Android_scatter.txt” file that you downloaded

  5. Select the twrp image you downloaded and do it for the boot and recovery partitions

  6. Press on “Download”.

  7. Connect the watch to the computer and wait until a green tick appears on the screen.

  8. Unplug your watch and power it on

  9. In the recovery, go to Install -> Install Zip and select the previously copied file “”

  10. Wait until it finishes and that’s it!


thank you for this, between your above files and instructions for TWRP, as well as the flash rom instructions provided by kospet on their website, the optimus pro HW/SW should last a long while. the whole community thanks you.


Good morning @iscle. I tried to flash TWRP following your instruction list, but had several error from SP Flash Tool you provided (5.1824 Win) when attempting to connect the watch with PC. So I stopped testing.
An I doing something wrong?

P.S.: you have my personal gratitude for your efforts!


I couldn’t test the SP Flash Tools bundle in this one as I don’t have the watch. What was the error you got?

Unfortunately I can’t remember.
Soon after I tried to flash TWRP my device wouldn’t boot, so I was so afraid that I have not considered in taking a screenshot.

1 Like

I found an issue in the “” file, but not on the SP Flash Tools…
Make sure you selected the correct scatter file! There’s no need to change the boot and recovery partitions, as they are selected automatically with the scatter.

This is the new file:!1XwRRSpK!Kum40v6YxP_k-LOaJecvwe0Ooh46VeSYOBRc6F7qjuU also updated in the post)


Thanks @iscle. I’ll give another thy later.

UPDATE: tested and fully working. I used TWRP to install Magisk and (after a moment of pure terror 'cause my watch seemed dead) Xposed Framework.
Now everything works perfectly.
Thank you @iscle for your great job!


1 Like

how did you install magisk? which version?
does it root the watch when installed?
how do I boot the watch in TWRP?
please advice :slight_smile:

Good evening,

I downloaded latest Magisk Manager .APK from their website and installed in on the watch. From the Magisk Manager app I downloaded the Magisk .zip that has to be flashed in recovery mode.
Then I used ADB commands (you can look on the internet on how to connect watch to your PC and use ADB) to reboot to recovery.
And finally I used TWRP recovery to flash the Magisk .zip file downloaded earlier.
At the end of the process when you reboot system, if you open Magisk Manager on the watch you will notice that you have Magisk installed and root privileges granted.
Let me know if you have other questions, and another time thanks to @iscle for his highly appreciated work.



thanks mate.
I had to do it a bit differently as I could not connect the ADB to my watch,
but everything worked perfectly at the end just as you said ( even the moment of pure terror you spoke of came along :slight_smile: )
do you think apps like greenify, amplify and such are worth installing on our watches?
I remember they worked wonders on some of my phones long ago

I would also like to extend my undying gratitude to mr. iscle

For the moment, I installed intelli3g which is an xposed module and performing battery tests.
Maybe I will consider Greenify for the future.
I will let you know

I am new to full android watches. what is the advantage of installing this.
or point me the direction where I can find this information
please advice. thanks.

This is a custom recovery. It is not easy to install ( I think the correct term is flash). If you’re not sure of what you’re doing I suggest you do nothing at all. More information about can be found here in the forum or in the XDA developers forum.

1 Like

okay i’m going to research on xda forum thanks

cool, please do.
I’m trying amplify.
looks promising

1 Like

Ok, I will. Let me know your progresses too.


I have been looking for this for a long time. Someone said the whole community thanks you and I can only come a poor second. Thanks again

1 Like

Any update on this?
I’m curious how the root xposed apps are working out on the pro.

Will this twrp work on kospet Optimus(2gb ram version)?

I guess many modules are working.
I tested personally
Intelli3g : working
Smart network: working better than intelli3g (more interesting options to manage network & synchronization)
Gravitybox: non working last version but I haven’t had time to test other versions.
Let me know if you need some other information