Ticwris Max TWRP / Root

Hello ,

I have researched the forum and learned how to use SP Flashtools . I even successfully flashed the LEMFO LENT firmware onto my TICWRIS just because I like it a little better :slight_smile: I am looking for the TWRP recovery file for the LEMFO LEMT / TICWRIS MAX . I have tried flashing a couple of links on the forum but the don’t seem to be the right ones . If anyone could take the time to assist me , I would really appreciate it . I’m new here and am enjoying the forum .

are you sure you have done it correctly? It’s not enough to only flash the twrp image to the recovery partition as it will be overwritten by the stock recovery, you have to either:

  • flash twrp to both the recovery partition and boot partition
  • boot into twrp and use it to install first the stock boot image and then magisk

or

  • flash a patched boot image to the boot partition at the same time you flash twrp to the recovery partition

Thank you for your response. I’m having difficulty finding the files . I do now understand that TWRP and the patched boot image need to be flashed together .

Can you point to where I can find a flash a patched boot image and boot partition for this device ?

I’m still having a lot of trouble rooting the Ticwris . I have followed Mininuke’s guide and research the forum and Google extensively. I keep getting a boot loop . The forum has taught me how to re- flash the watch so I’m able to recover it but I would really like to do this . If anyone could take the time assist me I really would appreciate it .

here’s what I’ve done so far so folks can see if I’m making a mistake :

From a clean factory reset :

I’ve replaced both the "boot " and the “recovery” in the Ticwris firmware with the TWRP image , then renamed both to “img” ( recovery/boot .img )

I have moved the original boot and recovery files to the sd card along with Magisk zip and apk .

I have installed the Magisk apk

I have deleted the history in Flashtool and loaded the new scatter file with the patched boot and recovery

I’ve unchecked everything except boot and recovery and replace those file locations with the TWRP image

I flash the device and wind up with the watch turning on and off loop

:stuck_out_tongue: I think I’m close I just need some help

I’ve rooted over 50 android devices. Somewhat new to watches but not new to the SP Flashtool. Copy Magisk patched boot image and magisk zip to watch, flash twrp to both the boot and recovery partition, boot watch (automatically boots into twrp), install patched boot image to boot partition, install magisk zip, done. If you are using Magisk then you need to use the Magisk app to modify the boot partition.
The above directions are a bit different then what I’m used to doing however these came from my notes on rooting and installing TWRP for the Kospet Prime. Since I assume your watch is an MTK device it should be the essentially the same. It sounds like you may have just missed flashing to patched boot image to the boot partition after you get booted into TWRP.
Note I changed this post several times after finding my notes

1 Like

Thank you ! I will try this again lol .

If the above notes don’t work I would try flashing your patched boot image to the boot partition TWRP to the recovery instead of flashing TWRP to both boot and recovery partitions initially. While I had the other way in my notes I don’t recall doing it that way. However for the Kospet I had pablo11’s already patched boot image and TWRP image in the whole firmware package that I just flashed all of it IIRC.

1 Like

A couple other thoughts if it hasn’t worked yet. Make sure you are using the scatter file for the ROM you are flashing. Consider flashing the entire ROM package but replace the boot image with the patched boot image and TWRP recovery image in place of the stock recovery image if you haven’t tried that already.

1 Like

Well I think it’s time to put on a pot of coffee :stuck_out_tongue: I went over this again and followed your tips to a " T" and the only thing that I can think of is that I’m using the wrong TWRP. Is recovery_C10_480X640_LFLT compatible with the Ticwris Max ( current firmware ) or was it just for the LEMFO LEMT ?

I believe it should work with that recovery. It is the one found here: LEM T Reviews and FAQs, right?

what new scatter file? The scatter file can be the same as before

Is it so that the name originally didn’t have .img in it and you added .img to the name when you changed it? If that is the case it might be the reason why it’s not working

I have also prepared two patched boot images you can try if you want (after flashing it together with twrp you have to use the adb command “adb reboot recovery” in order to boot to twrp):


2 Likes

Thank you very much . Yesterday I actually came close . It did reboot to try to load the TWRP but all I got was the green android robot . I will try these images now :slight_smile:

Could I trouble you to make a patched boot image for the LEMFO LEMT firmware? I only ask because I’m still not having any luck and the only thing I’m guessing at this point in the TWRP file is corrupt or can only work with the DM100/ LEMFO LEMT firmware . I’m not trying to be a pain lol I have to root this now ! :stuck_out_tongue: it’s really giving me a challenge haha!

Yes try noidremained’s patched boots but if that isn’t working here are some more thoughts:

When you flashed the LEMFO LENT firmware initially was the watch booting okay with that on it? If not that may be a problem. I’m also wondering if the scatter file for that might have messed up things for using TWRP or even booting. Another thing you might try since this has essentially the same hardware as the Kospet Prime is to install the TWRP being used on the Kospet.Prime.

Not sure at the moment if the TWRP you mention is compatible with Ticwris Max. I think if your not able to boot at all now I would start over by installing the stock Ticwris Max firmware and go from there.

1 Like

The watch boots fine on the LEMFO LEMT firmware

The build number for the firmware I’m on is :

DM100_LEMT_V2.0_20200713

ok, here’s a patched version of the lem t boot image:

1 Like

Thank you !!! Should be able to try this tomorrow again :stuck_out_tongue:

Do I flash the “patched boot” to boot into TWRP ? Or do I flash the “patched boot” and the Magisk zip once in TWRP ?

Edit . Still no luck haha. I’m gonna switch back to the Ticwris firmware and try that approach as suggested.

Edit #2

Well I think the watch won lol . After several attempts I decided that this isn’t happening lol Thank you everyone for your help . I really appreciate it and this forum .

I am sure you would not want to use TWRP to flash the patched boot. Use SP Flashtool to flash the patched boot. I’d say you can use TWRP to flash Magisk.zip though. Don’t give up

Maybe save it for when you are bored :wink:

1 Like

Thank you . I just can’t get into TWRP. lol

Perhaps you should accept your watch for the moment as it is.
Learn new things by reading the articles in this forum. If you understand everything, you will also be able to root your watch. Have a little more patience with you.

2 Likes