[request] TWRP and ROOT for LEM11

hello, i would like to request TWRP for lem11, i was looking through these forums and couldn’t find any so I’m requesting one, also will i be able to root the device this way ? i have not rooted a device in many months now and it’s my first time using android smartwatch.

you can’t unlock the bootloader on these watches and it’s not needed either, fastboot should have worked though (it have worked just fine on my watches). you did use “adb reboot bootloader” before “fastboot devices”, right?

1 Like

yeah, i did.

I must be lucky, I found twrp for it on my first try just now:

1 Like

ok so i found out that my bootloader was locked after trying to flash the twrp i got FAILED (remote: not allowed in locked state) then i was able to do fastboot devices so i tried to do fastboot oem unlock and it worked but it wants me to use volume keys, i tried holding down power button like on XDA website but nothing is happening.

you need sp flash tools from here: https://spflashtools.com/
then you need a scatter file, I can’t find the stock firmware for the lem 11 now but you can take the scatter from the lem t firmware(the scatter files is basically the same for all the mt6739 watches): LEM T Reviews and FAQs
flash in download only mode, then you can root it with magisk: https://magisk.me/zip/

1 Like

sp flash tool is not detecting my smartwatch, but adb and others do detect it.

The watch needs to be turned off to be detected. Have you looked at our YT channel tutorial ?

finally i have been able to use the sp flash tool, but do i not have to have bootloader unlocked ? if so how can i simulate volume up key event ? because without that i cannot unlock my bootloader. also i am not able to access twrp because it says no command.

1 Like

Okay, just do it like this one. as for TWRP use the one posted by noidremained


my smartwatch is now stuck in a bootloop! after few mins now theres no screen

I’ve had to deal with a bootloops on a watch and other Mediatek devices before and you can get out of it with just the right timing usually. You need to have your firmware loaded in SP flashtools and ready to push the start button. Have your cable plugged into the watch but not plugged in yet to the computer. You can click start button on SP flashtools and then need to plug in your watch just at the moment it is rebooting. That can be tricky if you have a constant black screen but if you keep trying you’ll eventually get it.

The other option is to wait until the battery runs down and the watch shuts off. If the battery is depleted and the watch is off you can then flash the firmware - might be best to flash the stock firmware at this point.

1 Like

I know, but i don’t have the stock firmware, only lemt and i actually accidentally flashed whole lemt firmware so i really really need lem11 stock firmware.

If you do a search you will find this version Z31-LEM11-V1.9 which I installed in my Lem 11 via OTA. However Iscle’s link is not working but you could message him and see if he can help. The search function is very useful.

1 Like

I did, hopefully he will mesaage me back soon, really need this.

1 Like