Official Support thread for LEM14

Yes ,thks.But I cant download! And cant reach Level 2,because in all threads about Lem14,last post is older than 14 days,except my post.Seems to be abandoned.I read all.I am an older Android user and I know enough to flash my watch,my phone or android media player.

Last stable one,please!

I read the threads from almost a month,from the momment i buyed that Lem14 watch .

You do not need to be posting in just one thread to increase your membership level.

You can post anywhere in the forum and it will count.
Why not go to the FAW firmware thread and ask a few questions?
You should be able to do that and find out what is required to use the firmware…
Does this make sense?


Thanks,alredy read all ,i saw the youtube.

1 Like

Trust Level 2 – Member

Members keep coming back to your community over a series of weeks; they have not only read, but actively participated long and consistently enough to be trusted with full citizenship.

Get to trust level 2 by…

  • Visiting at least 15 days, not sequentially
  • Casting at least 1 like
  • Receiving at least 1 like
  • Replying to at least 3 different topics
  • Entering at least 20 topics
  • Reading at least 100 posts
  • Spend a total of 60 minutes reading posts

This is not too hard, I guess. To make it easyer, I gave you a like… :wink:


Thanks very much @G1NT0N1C
Well done :+1:

1 Like

Thank you so much i am searching for it

@pablo11 is there any software for build number S10pro_LEM_C15_EN_V1.8_20221205

Nope, unfortunately not.
If it doesn’t show as an update…thats it.

1 Like

Hi, I wanted to ask you for help. I need to change the screen of the smartwatch, since the touch screen does not respond to me. Do you know what would be the best screen on Aliexpress for that model?


Forget it. It’s actually not possible to switch screens without destroying the Watch. So you would throw your good money after the bad money…
However, you should check whether the screen connector is not correctly connected. It is often sufficient to open the watch and press the connector firmly onto the circuit board.


Is it possible that the touch screen doesn’t work because of a software problem? I wonder why sometimes after I restart the watch it works for me, and then it stops working once the screen turns off.

Have you already tried a factory reset? Some apps like floating toucher can cause problems like that.

1 Like

Yes, but it didn’t work.

The other thing I did was apply the ROM that appears on the Rogbid page, but it generated another error. When the watch starts, it reaches the logo of the brand and restarts again, after several attempts it loads the operating system.

Will I have to install a new Firmware?

You should definitely do that. Install the original firmware. Use the “Firmware update” option in flashtool.
Your watch is a lemfo lem14? You can download the needed firmware here in the forum.


No, my watch is Rogbid Brave Pro.

I installed the Firmware from the Rogbid page, but it didn’t work for me. When turning on the watch, it remains in the logo of the brand.

Then I installed the Firmware of the Lem 14 and it didn’t work for me either. Same previous problem. When turning on the watch, it remains in the logo of the brand.

Now install the Lem 12 Firmware and the smartwatch is initialized, but the touch screen does not respond.

@Netxuz Did your watch work properly before you flashed any of the firmware that you have mentioned?
When you first received the watch, was it working properly?

Or did the screen become unresponsive after you flashed the firmware?


@pablo11 When I received the watch, it worked perfectly. After a while, the touch screen worked sometimes, I thought it was a software problem, and did a factory reset.

That did not work, then I installed the firmware from the Rogbid page, and there it appeared when the smartwarch started, it remained in the brand logo.

There I installed the Len14 firmware and I had the same problem that was left in the logo of the brand. Then install the Len12 firmware and the smartwatch could be initialized, but the touch screen did not work.

Thanks for the help in your answers.