Official LEM15 Thread

Hi all, I’ve had my LEM15 since early November. It’s on version 1.2 and I’ve gotten the hang of using it for the most part. The default launcher interface is kinda awful, and for certain notification bar conveniences I’m forced to open Nova launcher. The heart rate monitor isn’t accurate at all, unless I magically have a 86 heart rate while sprinting. The round screen in general is a nuisance and I find myself constantly in square mode for nearly all my apps. The cameras are pretty pathetic, although nifty to have. No volume buttons makes it kind of annoying to adjust volume on the fly. Battery life is fine though out the day, and only dies if I use it for long phone calls on speaker. For the most part, this device fits the bill on what I wanted with a watch-phone, because I run cross-country almost daily and now I don’t have a large device flailing around in my pocket.

Now, does anyone know how to root this watch model, and if there is another rom that can be installed? I’ve looked up lem15 root and found nothing on the web. It was discussed in this thread earlier in the year, but I haven’t found anything since. Something about using magisk, but that won’t work unless I have a custom recovery. I tried twrp through their app, but can’t find an option for lem15 under devices and then it crashes. Anyone here had success on this that can post instructions? I would much appreciate at least having root so I can play around with settings and optimizations for this device.

I would also love suggestions on round-screen friendly apps and such. There is no comprehensive list, so almost all the apps I’m using are square screen mode…

Thanks all!

Soon there will be our own FAW international firmware for this watch which is really cool . It will improve the performance of your watch . Rooting is pointless with A10 and not available .

As for apps you know they are designed for sqaure screens only so its not a failure of the watch . Its pretty much trial and error for all of us

Wait a little longer

Thanks

1 Like

@Dr_Andy_Vishnu is correct - root is next to useless for these Android 10 devices.
Trust me - many very experienced members have tried and gained root - only to find that it is pointless unless you want to use some Magisk systemless modules.
If you try to modify any of the images - like the “super image” (used to be called system in older versions) the watch will not boot.
Magisk creates a delta “so to speak” which is temporary and allows some root privileges - but not many, due to raised security in this android version.
Trying to do anything else is not possible - in a practical sense anyway.

We will release an “International version” soon which allows almost all apps to work on the device without issue.

People need to remember that these devices were produced in a country that has no access to Google or in fact 90% of the web (it’s easy to forget this). Therefore testing and troubleshooting G apps is almost impossible for them.
So, they created “work around” apps that do not require support from the big “G” :slight_smile:

This is where we try to help.
Not the brands. I mean the people who design the board and firmware for all these watches.
They asked for our help with this and so and we created the FAW International firmware version in cooperation with them.
We will provide access to it very soon.

5 Likes

You are very much right about rooting.
But not in everything, I think few want to change the basic system images, because it is really almost impossible.
But I find it ridiculous that some Lemfo watches support $ 3-400 LDAC bluetooth devices but don’t know $ 30 aptx devices. It’s also funny that Root privileges are required to turn a timed “Airplane” mode on and off.
There are many other little annoying things that any automation app (tasker, macrodroid, automate, etc.) will help if you have root options. That’s why I stay with the old factory kospet prime2 firmware.
There it is all possible.
I am very sorry that the FAW firmware no longer allows this option. :pray:
I also understand that you are tired of holding the hand of anyone who has no idea about the root process and bootloop or brick is the end of the attempt.
I want to make a movie about the root process and its benefits, but I don’t want you to get mad at me. That’s why I’m not making a movie about it yet.
But it would be good to find some intermediate solution. :+1: :wink: :slightly_smiling_face:

1 Like

Hello everyone, I’m really excited about the new firmware for the Lem15.
Hopefully it won’t take that long to develop. :upside_down_face:

Isn’t the Apple watch made in China? If so, it seems to be possible to get highly functional products from a “walled-in country”. I had hoped that full Andoid on a smartwatch wouldn’t be so much worse than Android on a poorly supported tablet or cellphone (like my Lenovo Tab M7) Sadly, I was overly optimistic.

It is not interesting where it is manufactured, but where it is designed and developed.
There are so many similarities between the two watch that you wear them on your wrist.
:thinking:You want to liken an “apple” to a “pear.” But this is not a “pear” but a “blueberry”. :face_with_raised_eyebrow:

2 Likes

Sorry, I don’t understand your analogy. I’m part of the group that would like a square full android watch in a formfactor comparable to the Apple watch. Seems that the Android world is against that formfactor. Is it an “Anti-Apple” thing?

Also, quality of manufacture is an issue of “interest”. By the time I get my defective smartwatch replacement from China it might be obsolete.

I was thinking with the analogy that you should not compare a watch designed in America and made in China with a watch designed in China and basically made for the Chinese market.
This is not about quality but about the services available.
Many people want a square display FAW watch.
Unfortunately, this is not as simple as many people think. Currently, a lot of models are falling victim to the chip and display crisis.
Only plan from what is available, but at the moment everything is uncertain.
For example, an NFC chip has a delivery time of more than one year. It is no coincidence that new good models barely appeared in 2021.

1 Like

Please can you give procedure how I flash this
should I change the rar to zip? and use a flashing tool?
My lemfo15 boots to blank screen after I installed nova launcher
If I have psed this in wrong thread appology in adavnce still a rookie

Hi . You will need this firmware . Download to your desktop and unzip

Read this ( use firmware upgrade )

Tools required

1 Like

sorry one last question should I change the extension of the FW from RAR to zip? to use the flashing tool that you provided
Cheer!

God bles thx

1 Like

Yes . From rar to zip to unzip

1 Like

Hi Doc I was wondering since the PC recognises the internal drive of lem 15 is there a way of uninstalling the NOVA launcher or do a factory reset from there I se the android folder is there a folder in this where the apps are shown? If I can uninstall the NOVA than I do not have to flash the FW

I cannot see how that is possible .

These are hard to find on a blank screen.
Don’t you remember to what he asked for help from yesterday? :wink: :+1:

1 Like

Yes . I missed that :rofl:

1 Like

As far as I know , LDAC codec is free from sony since android 8 . About the aptx codec even if the chipset used supports some aptx family codecs, I suppose that the manufacturer has to pay qualcom for using them .

That’s right.
The difference is that android9 and android10 support aptx code in software without a ‘qualcom’ chipset.
I also know that aptx is licensed to qualcom.
But you can install it for yourself later. But this requires root.