No google play store

Hi all,
after updating my Kospet Prime SE to 1.5 and doing a full factory reset, my Google Play store app has disappeared. Anyone know how i can get it back.

Related to this ?


hi Eric
tried downloading from my watch and it came up unsuccessful.
tried downloading from computer. mac and windows and it says " file does not have app associated with it…install an pp or create an association in default apps settings page,"
i dont what app to install or how to create one??

any help thanks

Apk is the Android application format, it will only work on your watch.

Hi . Download this to your desktop - mac and unzip if required -

Connect your watch to computer and open files ( downloads ) . Drag this file into downloads folder

Reboot watch and when starts open download folder and tap on .apk file . Playstore should install .

Please not i have not tested this nor tried this before as i have not heard of anyone have playstore disappear . If all else fails flash the latest firmware.


if it can help Kospet Prime firmware Updated 15 August 2020