My screen on Kronosblade Genesis is totally black

My screen on Kronosblade Genesis is totally black. I can hear it start but the screen dosen’t.

Hi . Can you explain what you did prior to this . For example did you load a clockskin .

I didnt do nothing, the clock was empty so I recharged it. When I heard the sound that tells that it full, I start the watch. It start to play the Genesis start-up-song, but it totally black.

So when it goes black is it still on ( just no screen ? ). The reason i ask is maybe it hasnt really charged fully . When you press and hold the power button does a menu appear

It’s fullt charged. If I push the buttons the clock vibrates.

I don’t see anything on the screen just hear

Try pressing and holding both buttons together for 30 - 50 seconds and see if boots up

It’s boot but it’s black

This behaviour is typical when you install a bad clockskin but if you havent done this fair enough .

I use Genesis original clockskin

Have you flashed a watch before with firmware ?

I already done this, still the same problem

So after you flashed the firmware its exactly the same ?

Yes, the same problem. I hear it start but the screen is black

No offence but reading your earlier posts you appear to be inexperienced with flashing watches .

This is only a last resort if all else fails . You may have made a mistake and messed up your watch previously

Yes that is true, I am inexperienced with smartwatches, cause it’s my first one. But I made it that time with better information. And this time it was no problems with the scatterfile

So when you flashed the first time the watch worked fine afterwards . This is a new problem ?

I have two Genesis clocks, this one I have not flashed before

There can be several reasons :

  • screen is dead
  • screen is disconnected inside the watch
  • wrong FW

The usual one is a wrong FW adressing another screen hw, but in your case, as we have only one FW, it shoudn’t be this problem.

1 Like

So, what to do ?