Lem14 freez on black screen after update an app

My lem14 stuck in black screen after i update aoos from Google play i think one of the app called (Android System…) i cant remember the rest.
I just made update all
Then i found it freezed and no responding at all
But when i connect it to power pank it recharge because i can see light on power bank after i connect it.
When i connect it to laptop it connect but show me as usb port connect
Cant see the files and no responding from the watch
Even no sign of battery recharge icon on the watch just black screen
So please help any ideas???

Dont panick . All can be fixed . Firstly let the watch die and when charged start watch . all maybe will be okay but i doubt it .

Second thing is to flash the firmware

Take your time . Read carefully and you will be okay

Did you have any third party apps like floating touch or anything that needs the permission to “display over other apps”?
This is usually the cause of the screen becoming unresponsive.

I also advise you to use the usb cable directly attached to the watch until you have flashed the firmware and got it working again.

The dock is ok for charging the battery but personally I never use the dock when I need to connect to the watch.
Some people do, but I believe it is just another link in the chain that can cause issues for things like flashing firmware etcy…


I tried for 2 days now and i couldnt pass this step

Try firmware upgrade instead of download

I’m assuming watch is turned off and you are using correct firmware ?

I cant switch the watch on or off its just black screen

You can’t use firmware upgrade option and not select the preloader. That is causing this error message.
You need to do some research about flashing MTK devices using SP flash tools.

Most importantly NEVER use format all + download.!!!

@Mohamed_Ateya which firmware package did you download?

Hi Pablo,
As I mentioned, the watch shows black screen, but I know it’s connected by looking at Device Manager, it shows "MediaTek USB Port (COM3).
I was using the Scatter file only (no firmware), that’s why the previous screenshot showed “No image file Exist”
But now I’m using the correct firmware from Official Support thread for LEM14 (file name is: S10PRO_LEM_C15_EN_V1.7_20210121.zip).

I selected “Firmware Upgrade” then clicked on Download button. It showed an error message
with error code “0xC0010005” after almost 2 minutes. I tried again, but it always shows the same error code.

I tried using a different version of SP Flash Tool SP_Flash_Tool_v5.2124_Win but it didn’t make a difference. (originally I was using SP Flash Tool v5.1924.00)
Here is the error message in the logs.

10/23/2021 20:44:37.088 FlashTool[5392][3228][D]: APCore::ConnMediaUSB::PreConnect(): USB port detected: \\?\usb#vid_0e8d&pid_0003#6&1958333f&0&2#{a5dcbf10-6530-11d2-901f-00c04fb951ed}(..\..\flashtool\Conn\ConnMedia.cpp,71)
10/23/2021 20:44:43.430 FlashTool[5392][3228][D]: APCore::Connection::ConnectBROM(): BROM connected(..\..\flashtool\Conn\Connection.cpp,85)
10/23/2021 20:44:43.432 FlashTool[5392][3228][D]: APCore::Connection::ConnectDA(): Downloading & Connecting to DA...(..\..\flashtool\Conn\Connection.cpp,129)
10/23/2021 20:44:43.432 FlashTool[5392][3228][D]: APCore::Connection::ConnectDA(): connect DA end stage: 2, enable DRAM in 1st DA: 0(..\..\flashtool\Conn\Connection.cpp,133)
10/23/2021 20:46:55.227 FlashTool[5392][3228][D]: APCore::Connection::ConnectDA(): Failed to Connect DA: STATUS_PROTOCOL_ERR(-1073676283)(..\..\flashtool\Conn\Connection.cpp,148)
10/23/2021 20:46:55.230 FlashTool[5392][3228][D]: APCore::Connection::Disconnect(): Disconnect!(..\..\flashtool\Conn\Connection.cpp,186)
10/23/2021 20:46:55.702 FlashTool[5392][3228][D]: BackgroundWorker::run(): BROM Exception! ( ERROR : STATUS_PROTOCOL_ERR (0xC0010005)

Can you please help?

exit the flash tool.
start the device manager
plug in your watch.
check the device manager
(a “preloader port USB VCOM Port” appears between ports for a few seconds)


If this is okay, disconnect the watch
launch the “firmware update” in the flash tool and click the download button.
And just after that, plug in your watch.

thank you gyuri
i tried the steps that u mentioned but its still the same error
what else can I do guys???

Is the mediatek driver installed correctly?
Try installing this: Download MTK Driver Auto Installer (all versions) - Best Mediatek Drivers

Hi again, thanks for the link. I went to Device Manager, uninstalled the device driver, then downloaded the file from the link you provided, installed the new drivers, rebooted Windows. However, the SP Flash Tool still shows the same error code.
Any thoughts? thanks in advance.

You do not need to try the SP Flash Tools until the “Preloader USB” driver appears in the device manager. What does the device manager write now?

Device Manager still shows the same device in the screenshot MediaTek USB Port (COM3)

I tried another laptop, installed the driver first, rebooted Windows, then connected the smartwatch USB cable. I opened Device Manager and it shows the same device driver description, but with different port number: MediaTek USB Port (COM8).

I tried to run SP Flash Tool again using the steps you mentioned earlier but still the same error message and error code “0xC0010005”

I think the driver is installed correctly, but there’s something else that block the flash tool from communicating with the smartwatch. What do you think? Any advice is appreciated.

Hold the power button until you get a reaction. I’m guessing it will take between thirty seconds and a minute, but don’t give up even if it takes a little longer. After that you can try flashing again


Hi noidremained, If I hold the power button, the “MediaTek USB Port (COM8)” disappears from device manager after almost 10 seconds. If I keep holding the power button longer, it will reconnect the smartwatch after few seconds (maybe 5?) and “MediaTek USB Port (COM8)” will re-appear in Device Manager. This keeps happening as long as I’m pressing the power button, but nothing new appears in Device Manager.

and still the same error message when you try to flash it? (I’ve seen the advice from @gyuri, but I’m not sure if “Preloader USB” will show long enough for you to be able to see it) In that case I guess my theory was wrong. Next advice from me is to buy a new cable

Yes I tried again and it’s still the same error message after almost two minutes from pressing the Download button. The “PreLoader USB VCOM” is not in the Device Manager list, but maybe it’s the same as “MediaTek USB Port” and the name is just different. I’m not sure though.

It’s not easy to purchase a new cable from where I currently live, I’ll try to do this, but this will take too long (a month or more).

In the meanwhile, is there anything else I can try? Thank you all for your help so far, and looking forward to your advice.

@gyuri @noidremained @Dr_Andy_Vishnu @pablo11