Kospet Prime S teething trouble

Creating this for people who have any problems with the Prime S.
As it is a new system it is difficult to flash this chipset.
We will discuss this here

Got a warning for everyone, and I need your help. Everything was going great setting up my PRIME S until it booted into a black screen. It appears to me to be that old issue in early Android watches where the watch face index would get corrupted and the watch would hang on boot never going into a watch screen. Yes, I did side load some faces to try them out. Did the normal thing of tapping the curved arrow at the end of the face thumbnails and all worked normally. Stock faces, installed faces, all fine. I side loaded a couple of apps, and then it happened. Reboot and the black screen of death.

On the charging wire I get the green circle display with time and power level and the watch does charge properly. Swiping to the right, which usually switches back to watch face, switches back to black screen. From black screen no swipes work, so I can’t get to app section to do factory restore.

Power button push works and brings up typical menu, and power off and reboot work fine, but boots back into black screen. Hard reboot of holding both buttons for 30 sec or so reboots into the black screen.

I remember when Pablo11 studied this that the only way out was to flash (which is why he created the reload watch face directory arrow thing to save us all this fate). Well unless I’m wrong, I’m there on this new PRIME S. Touch and hold does nothing. Swiping does nothing. Only the power button and connecting to a charger changes the screen.

It’s not totally black, mind you. The backlight is on and stays on for the duration of the set time, which is 5 minutes on mine. Then it shuts off.

Oh, and you can’t power this watch down and have it on the charger. It seems to want to power on and stay on during charging.


Call for help: How do I get out of this guys since there’s no way to flash it? I can mount the watch to a computer still and load/remove items. I took all the faces out of the clockskin folder but that didn’t work. Any remote way to refresh the clockskin directory?

Good morning Mr Ticks . I noticed also you cannot power of while charging . I have had this issue before on other watches . Personally i would have left the clockskins in the folder at first then tried this trick . As the watch reboots try -

Usually takes a few goes as you have to be really fast but i have saved many a watch this way :+1:

1 Like

That sounds like something you guys would take bets to see if you can get Mr. Ticks to do something stupid over and over! For real? Swipe really really fast? Guess faster and faster processors makes it worse than the old HOPE 32GB. Well, here goes. Gonna down a beer first to improve my reaction time. I’ll let you know.

Do ya think sticking my finger up my nose to get it slimy would make it slide faster across the screen in that millisecond of opportunity?

Well, here goes. I’ll let you know. Got a fresh cold 6 pack and enough frustration to last a couple of hours on this. Really appreciate the guidance (I think). I’m beginning to understand why you’re the Doctor in the group.


Haha . The old tricks are the best :+1:

I should have prescribed beer as it does help so best of luck :wink:

The sad thing is that the firmware flash process for this chipset is not for your everyday user at all.

It is much different to MTK and others.
So I have a way to fix Mr Ticks watch but I can’t do it today because I am working.

But hopefully tomorrow we can do it.
Mr Ticks is going to need a Windows pc and google Chrome browser on the pc.

@SmartWatch_Ticks will this be ok?


Absolutely @pablo11 We can do this! I’ve got a Windows 10 PC with the drivers installed for regular flashing, and Chrome is on it as well. We’re good to go! Thanks for all the help.

1 Like

No worries.

Can you please elaborate on the slime thing?
Is this possibly a way to lube the chains of my motorcycle?
Ever thought about patents?
Is a certain finger recommended? :grin:

I’ve experimented a little and I’ve found a way that might work. If I’ve got it right, long press works to open the power off menu. Unfortunately, I did not manage to duplicate your problem and put my Prime S in the same state. But from the power off menu I am able to do the following: Scroll down the power off menu to “recent task”. If you had an app open before the problem occurred, it will be displayed here. Tap on it to open. If you are now in an open app, you should be able to enter the app drawer by swiping from left to right (hopefully). From here you can do a factory reset. I would try to delete the custom faces from the memory first. I hope this works for you. Unfortunately I have not yet been able to reproduce this problem in order to test this way.


After talking to the designer it seems that it may be this watch face (built in) that caused the launcher to crash and refuse to display anything.

Mr Ticks was not even using a custom face at the time.

But I will find out more today.

@G1NT0N1C is spot on … I had the same black screen issue with my Kospet Prime_SE several weeks ago.

My issue was caused (I believe) by a flawed animated clockskin which I designed and was testing out. After loading it, the black screen of death appeared and from there all I could get was the default power off screen. I repeatedly tried the ‘quick-swipe method’ while re-booting with no luck, however, I did notice that ‘recent task’ option was available via the power off screen and I was able to get to the settings list from that and factory reset. (A7 of course)

1 Like

Yes that’s definitely a thing.

But this situation is slightly different in that it is a chipset that behaves differently and so does the launcher.

It’s slight but it is a difference.
Mr Ticks is able to mount the storage and access the files but it is not helping.
This launcher appears to have locked the files.

We will try the recent tasks trick and prey :joy:
Because flashing the firmware on this unisoc chipset is not for the feint hearted :sweat_smile:

1 Like

Thanks :smile: :stuck_out_tongue_winking_eye: @pablo11 … I’m a Mac user … flashing is an alien task to me.

The good Dr Andy is right (Who’d have ever believed it?! :crazy_face:) I have used this method myself to get out of the dreaded “Black screen face” And if a ham fisted 68 year old can swipe fast enough, it outa be a breeze for someone with a six pack inside of him Mr @SmartWatch_Ticks !!:rofl: Try sculling all six beers before you start swiping! Cheers, Doons

1 Like

Ah, @Dr_Andy_Vishnu and @Doonsbury, madly swiping my screen like counting winnings in Vegas didn’t work. I swiped and slimed and slipped and even drooled (or was it spit, can’t remember after the 6 pack). Absolutely no indication it was going to do anything differently ever, and a whole lot of time between restarts to get to that precious milisecond window over and over again. If it does work, it’s a real art. Shame.

What’s more a shame is the @G1NT0N1C idea of using Recent Tasks to bring up an already open app to gain access to the app drawer via a swipe from there. The shame is on me for getting bored and actually clearing all recent apps out of there before trying to tap any one of about 10 open apps. Duh! So stupid! Why didn’t I think of trying that! Well, I don’t know if it would work or not as I tidied up my mess like I usually do before putting a watch to bed.

Here’s what I CAN do. I can tap to switch modes, which it tries, says it does, but doesn’t really do it as when I try it again it still wants to go into Sports, so it never switched in the first place. I really love run-on sentences. Makes you think and read it a couple of times.

Here’s the good part. When checking Recent Tasks, sure enough, there’s listed the task of switching to Sports mode as a ‘task’ entitled WiiteSystemUI. Tapping it brings back up the switch screen, but, being a system thing I guess, I can’t swipe over to the app drawer when it’s on the screen. Swipe right closes everything, including the trash can, and swiping left clears this task just leaving the trash can and a black screen. Tapping the trash can says ‘Nothing to clear in cache’. Swiping right clears the trash back to nothingness. Darn! So close!

Like @pablo11 says, this appears to be a whole different beast with the new processors involved, so we may need some new straws to grasp. I really like the @G1NT0N1C recent task trick though, as it appears it just mighta worked. If I had only left the recent apps alone. Grrrrrr.

The black screen of death persists. The saga continues.


I have prepared for fixing your problem.
It scared the hell out of me when I flashed mine and thought it was a gonner.
But I understand it now.
I have sent you something in preparation for tomorrow.
It is going to be emotional :sweat_smile:


I beg your pardon…?
Watch it sunshine.

Big Job :rofl::rofl::+1:

Consider it watched (And deleted) @pablo11 Cheers, Doons