Constantly disconnects and reconnects to phone through Watch Droid

After setting up my new Kospet Prime S (purchased directly from Kospet) I am finding that it constantly disconnects from my phone and reconnects nearly immediately. I’ve found a temporary solution to it - Open Watch Droid on both my phone and my watch for a few seconds every time I restart or make a big change on my watch, but I feel like this shouldn’t be an issue.

Another, smaller issue I’ve found with my watch is when I have location turned on, I constantly get ‘GPS Found’ followed by ‘Bad Response’ over and over for as long as ‘Location’ is set to enabled.

Any help with either of these solutions would be greatly appreciated. Other than these 2 minor issues, I haven’t been having any issues with the watch and am loving every second of owning it!

Read this for any app you want to run in the background

Did you factory reset your watch before you first used it ? If not its advisable

2 Likes

this sounds like the problem that arose in UL, I think it should be fixed if you update to the newest version (3.5.2)

2 Likes

@noidremained is right. Here is the link to the latest version, V 3.5.3:

2 Likes

I knew i’d seen it somewhere before :rofl::+1:

1 Like

I gave that a try (Uninstalling my UL and reinstalling using the link shared above) and when I attempt the install process, it says “App not installed” with no details of why. I’ve tried restarting the watch as well, it doesn’t seem to want to cooperate with the APK.

My opinion is that the permissions are messed up after installation and removing UL.
My advice is to factory reset the device and install watch droid first on its own and test it.
Make sure you have granted ALL the correct permissions for Watch Droid.

If everything is fine then proceed with installing UL.
I really don’t think it is a good idea to download it to the watch and then install.

It is much better to download UL to your pc and then transfer it to the watch using the usb cable.

Just my opinion…

By the way @BforBrian did you contact Kospet about this?
I am only asking because they contacted me and asked me the exact same question… :thinking:

It’s not a problem of course, just curious about the coincidence :+1::+1:

1 Like

I’ve done another factory reset and went - connect to WiFi, install Watch Droid, connect it, download UL again and installed it (the latest version). It installed fine this time and so far things seem to be working great. I’ll update/edit this post in the morning to let you know how it gets through the night and my morning.

I did not contact Kospet about this! Weird haha. :thinking:

Side question - Is there a charging dock that is compatible with the Prime S?

Thanks for the help!

Not that we know of…
By the way, I seriously meant what I said about this watch and installing apps - in the official support thread.

1gb ram… Just think about it.

The OS and Google alone requires almost all of the available ram.

It is very easy to get locked up with this watch because it is intended to be a low budget watch for people who don’t want to run lots of apps.

The other thing is that flashing firmware on these unisoc devices is not a walk in the park.

So please heed my warning - don’t push it too hard.

Just don’t want to hear that you have bricked your watch… In a few days time.

2 Likes

Yes, if you brick your watch, we can’t help. It is then a paperweight for all time.

2 Likes

Correct you dont have much free ram , i have tested it and most of the time you have 430mb free , streaming apps work without any lag , as long as you use only 1 app at a time and close the app fully you can do alot even seen a youtube video of some idiot playing fortnight on that small screen and it worked , its funny to see people pushing the limits to see what can and what cant run.

Yeah I did see the above linked post regarding it being a budget device, etc. even before making the purchase. Like you’ve said, it works surprisingly well for such low specs. I haven’t had many issues with it really. I’ve even loaded up some RuneScape and it ran great (Although I won’t be using it for that… Although maybe use the watch as a remote mouse for the game on my phone? Lol) and like mentioned, I’ve just got to make sure to completely close the app when done.

Overall though, the solution above worked for me. Everything seems to be working now, my watch hasn’t disconnected yet. Thanks for the helps guys!

Cool, good to hear.
Basically, we have to warn people because some people have very different opinions about what they do with a smart watch…lol
As you have probably noticed :joy:

However, because the chipset in these devices is not the usual MTK - fixing boot errors and flashing is quite different and it seems prudent to warn against overloading a device which only has 1gb ram.

So far it seems like as long as I don’t run too intense of a watch face I should be fine with my planned daily usage.

Fortunately I am a bit of a tech nerd and understand what’s going on for the most part - I am just completely new to smart watches, this being my second one ever, my first being a second-hand Gear S2 Classic (did not like). I should pick up on all of it fairly quickly, especially with the kind of help this forum provides :slight_smile:

The only downside I am finding to this watch so far is that there is only the charging cable that comes in the box. I would really appreciate a charging dock, or a dock that would allow me to slip the current charging cable in and mount it to use as a dock. Kospet, if you see this, I’ll buy this so fast and I’m sure I’m not alone! :wink:

I will pass this on, but it may be that one of the other brands who are selling the same product under a different name has already done it.

If this is the case I will let you know.

Personally, I am the opposite.
I don’t trust docks at all and I consider them to be a weak link in the chain of connection to my PC.
I will always use direct USB cable if possible, but it’s a personal choice of course :+1:

Also with charging docks you never know when its fully charged as you see a red led and it does not change colour like bluetooth earbuds in its charging box

Replying to both of you -

Really the only time I connect my watch to any cable is to charge it through the night (I use a separate watch for fitness and sleep tracking) and haven’t really had a need to connect the watch to my PC at all yet since I’ve got a media center set up to stream/share most of my needs.

Yeah if you do find something please do let me know. I wouldn’t mind paying a few dollars for it. I saw one on Amazon that was discontinued but I can’t remember the name of the brand. I asked a question on the Amazon page, “Is this compatible with the Kospet Prime S” and someone did say yes, although this isn’t the most reliable source of information…

Edit: Piggybacking off this comment so I don’t have to double post or make an unnecessary thread - Is there any reason why the Galaxy Wearable app doesn’t appear in the Play Store on the watch? Am I safe to download an APK of it? My main goal for this watch is simply music and assistant with a decent face. I’ve got Galaxy Buds Plus and miss out on a lot of features not having the app for it.

And what I believe should be my last question - Is there a guide to using WatchMaker on full Android watches?

Have you checked the watch face development section here?
As for a guide to Watchmaker - it is a third party app and even though we are kind of related, we don’t host any Watchmaker stuff.
You need to visit their website for this information.
There is a link at the top of the forum here to Watch Aware who are great people and have a lot of stuff about making .watch type faces.
We are kind of affiliated with them.
Check out the watch face section here and Watch Aware for starters and I don’t think the galaxy app will show up in the play store on the Prime S because it is not a compatible device - same as all of these devices.

I’ll have a good look over at WatchAWear then, thanks.

As for the Galaxy Wearable app, does that mean that it would certainly cause issues though on my phone or just straight up not work? I’ve downloaded APK’s on to “incompatible” devices without issue, but of course that was on phones.

Watchmaker is an app to design watchfaces. If you mean being able to use those watchfaces, then there’s several ways, the main one is using universal launcher available on this forum. There’s also a wallpaper and a tweaked watchmaker app.