Weather app on LEM 14

Hi - I posted this on another thread before I knew of the existence of this one, apologies. I got my LEM 14 yesterday and of course it’s great, though I can’t get the inbuilt Weather app to connect and download weather. This means that any face offering weather or temperature information won’t work. Other apps using GPS or Location (which is on) work fine - Maps, downloaded weather apps etc - but I get ‘failed to obtain location information’ after a while of it trying to connect, then it just keeps trying and trying without success.
Any suggestions? I’ve gone back to factory settings once for another issue but it didn’t fix this one.

Do you have a SIM ? The weather app seems to have a strange dependancy on the mobile data…


Thanks for the reply - no, I don’t, but it’s connected by wifi and the other weather apps (and Maps) are happy to work through that and GPS. It’s stock Android, too, so I can’t believe they’d make its functioning dependent on having a SIM!
Thanks anyway

It’s dependent on location.
So if you go to location settings and enable Google location accuracy it should work with WiFi and GPS turned on.
After you have an update you can turn GPS off and hopefully it will work from then on.

Thanks for the reply, Pablo.
All of those settings are on. In settings/location/app permissions, the Weather app is listed as ‘Allowed all the time’. When I click on the Weather app icon, it opens a page called ‘Location access for this app’ but it’s very dim. The button for ‘Allowed all the time’ is chosen but it won’t let me choose anything else anyway. If I click ‘See all weather permissions’ another window shows buttons for Location, Storage, watch - all of them very dim and unchangeable by me, but all seemingly switched to the on position (hard to tell because the screen is so dim and won’t lighten).

Is there another switch somewhere for GPS? Or is it just this ‘Location’ app? As I said, other apps that depend on GPS or wifi for location seem to work - Maps, etc. I just can’t crack this weather app!

Is Google location accuracy enabled?

Hi - yes, it’s on, as is Google Location history. The one switch in that list that’s off is Google Location Sharing, but when I open it I get a dimmed page with the Location icon slashed through (i.e. not on) and " You aren’t sharing your real time location with anyone on Google" … which is probably a good thing, and doesn’t seem to be anything I can change on the watch anyway. In the list of Apps using the location permission, 7 of 9, Weather is allowed all the time, alongside Maps, Gallery, Connect phone etc. Maps certainly uses Location and works okay. Another app I downloaded, Weather Forecast, has permission ‘only while in use’ - so it comes on when I load the app. And that works. I’m baffled!

Ok thanks.
I will report it but I can’t replicate the problem with mine.

What area do you live in?

Okay, thanks. I’m in France, halfway between Poitiers and Limoges.

Strange indeed.
I’m in Australia and it’s working.
But I might ask
What do you think guys?

1 Like

I guess @Dotsfar is right. It need a SIM card to make it work the 1st time, I don’t know why.
But I will have a look when I’m back home.


Thanks G.
In this case it seems to me that AGPS is required but the fact that cellular data is needed and WiFi is not working for you - this is indeed a problem that needs to be looked at.

1 Like

If a Google account is registered (or not) and Google location accuracy is enabled and it still does not work…
This is a worry.

1 Like

Excuse my ignorance … what’s AGPS? Something GPS?

So it’s normally like this.
The first time you use the weather app you need data (Wifi or cellular).
GPS so location services can work.
And Google location accuracy enabled.

After this first time you should be able to use just Wi-Fi and not need GPS.

AGPS = assisted GPS.
This means that data connection is assisting.

However, I have tested GPS only and after 5 - 10 minutes I can get a satellite lock.

So I am curious to see what is causing this problem.

1 Like

Incidentally, thanks guys for all the help. Much appreciated by a newbie! I’m reasonably adept with tech and learning new apps so this is frustrating when something doesn’t seem to work properly. Also have to say, a little disappointed with the battery life on the LEM 14. I’d been using my backup Ticwatch E while waiting for the LEM to be delivered, and at least with that there was an always-on screen which wasn’t dependent on Lift to Wake, and I was getting almost 24 hours out of the battery. With the LEM I’ve pared everything right back to get 24 hours, but that means no always-on screen and having to tap the power button to show a screen. (I tried Always on Amoled but didn’t like the way the screen moved around, up off the face, so uninstalled.) Still and all, it’s a nice watch and hopefully updates will continue to improve the implementation of A10.

1/ Is there a separate app for GPS that you can download, other than the Location app? How do you know you’ve got a satellite lock?
2/ Would a factory reset (again) solve the problem? I’ve done that once with no effect and it was a pain to get the watch to pair again with my phone - though this time I’d have droid watch instead of the useless WiiWatch app.

As i always have a sim in all watches i test i have never had this issue on any watches .

I will check

1 Like

Well I downloaded an app called GPS Data and went outside to ensure I got a lock - in the open I got 6 satellite locks. I tried the Weather app but it wanted connection to a WLAN and I was just too far away from my router. So I went and stood in the courtyard behind my house and got 3-4 satellites and a strong signal from my router (using the router’s own broadcast, not the extender I’d been using before). I tried with the wifi off and on, with the GPS/Location off and on, with both on (not both off, that would be silly) … and I always get the same lower-case message from the Weather app: failed to obtain location information. While trying to connect it shows the 5 white bars rising and falling, then it gives me that message; then the message goes away and it keeps trying to connect but after 5 minutes, nothing doing. I may have to try another factory reset but I’m not looking forward to it …

Incidentally, a propos of nothing at all, the magnetic connection/charger is the worst POS connection I’ve ever had - feeble magnets. I’ve ordered the charging block from AliExpress (it didn’t come in my delivery from Banggood) but that’s going to be 2-3 weeks and another $29.