Watch unresponsive to activated SIM

My KBGenesis watch is unresponsive to an inserted fully activated SIM. I searched to see if anyone had a SIM card issue similar to mine but found none. Firt, in the connection section only the “cellular network” section remains greyed out. There is no toggle switch to turn it on. It does not light up even after inserting the SIM. After trying a call the notification keep saying " insert SIM" and not registered on network. I see no way to access APN set up. The SIM works n my Gear S. Someone please help I need to use this watch for calls. thanks

Have you already try to reboot the watch?

1 Like

Oh yes…Rebooted several times times

Is the SIM installed correctly? I think you know that you have move the metalslider up to hear a “click”?

1 Like

Did you make a factory reset?

1 Like

Just for giggles, what network does the sim and Gear S work on?

1 Like

APN setup page is under, Settings/Connect/Cellular network/Access Point Names. Also make sure the watch is not in Airplane Mode or that function will be greyed out.

Thanks Jonathan-Airplane mode is off, cellular network is greyed out, so no access to APN setup.

Initially the metal slide popped out but I put it back and it still slides up. However, a distinct lock click is not really heard but the card seems to be firmly in place. I also did a factory reset. The SIM is a Speed talk and I assume it runs on T-Mobile network. I ran the Gear S once on US Mobile network I also tried my post paid T-mobile SIM but it didn’t work. The Gear S does not work on this post paid either but on this speed talk. . I slide the SIM in with the apex cutoff down…

Do you have another Sim card you can install. Try the one in your phone if you can.

There is a click if you done it right. Make sure that your SIM is installed in the right way. Are you sure that you did not turn it 180° by mistake?


So desperate, tried every possible turn-including the right one and no difference.

Jonathan-I tried another woking SIM but no response-cellular network still greyed out

Sorry… Speed talk.
Have you checked on their website for supported bands?
Then you can check the supported bands for the watch in the proper Genesis thread

The SIM is from SpeedTalk GSM Mobile

LTE bands available for the Genesis are:

MySIM provider: For my location 4G LTE is only on Band 12. 3G and 2G are on Band 2. That’s all available.

Just for your information I use Speed Talk Sim Cards in my watches including the Genesis. I installed a new card after activation and it came on line with minimal wait without any set up required. So they do work very well on any band 2G, 3G or 4G in my location N Florida.

Thanks for the assurance Jonathan-I agree they work because this particular SIm works in my Note 8 and my Gear S but just not in my Genesis. I just can’t understand

Yep sounds good.
Mr Ticks uses TMobile so I would guess it should work.