TICWRIS Firmware V 1.3

I got a notification of new firmware on my LEMFO with Ticwris firmware of a new version V1.3

Anyone installed this firmware or has any idea what changes there are?

My Watch is also rooted.

I have tried updating but got an error. Tried it several times. Haven’t looked into the reason why the upgrade doesn’t work.

Yeah, tried a few times myself. Must be because I only flashed the system files…
What we need is a download of the update to flash with flashtools.
Might get it to work then but my watch isn’t rooted so can’t extract the flash file. Also haven’t found it online either…

I have tried updating using TWRP but I get a fingerprint error. The finger print of the update.zip file is different then the finger print of the current installed system. I installed the TicWris firmware with a different boot.img.

Hi. Please can you let me know what files you used to root your ticwris Max and also twrp.

The procedure is laid down

1 Like

Thank you for the reply. Is is possible to post the TWRP to mega, dropbox, google drive or something else and send me a link please as for some reason the link for TWRP is not loading for me.

Change in link “discourse.fullandroidwatch.com” to "discourse.fullandroidwatch.org"

1 Like