S08 Firmware thread

Flashing tools including 7zip extractor

Latest version v1.4

Early edition with Google fix v1.2

You will wipe the watch doing this.
Backup data if needed.
This firmware is for the 3g + 32gb Rollme S08.

Use the flash kit linked above
Power off the watch.
Install 7zip - included in the pack
Install drivers
Unpack the firmware folder to your desktop
Unpack the Flash Tool to your desktop and click on the little .exe file
Load the M6739 scatter file located in the images folder inside the firmware folder.
The flash tool will now automatically load all the images.
Now make sure USB cable is securely attached to your watch.
Test the connection by plugging in the USB to the PC and see if it charges - then unplug.
Make sure watch is still powered off.
In the flash tool window - select “firmware upgrade”

Then click on the green download arrow icon on the Flash Tool.
Now you connect the USB cable to your PC and it will flash automatically.
You MUST NOT disturb the watch at all until it is finished !!

Mr Tick’s video is still pretty much the same - as is the one on our YouTube channel - link at top of the forum in the banner.
This one is ok too but the only difference is you must select firmware upgrade.

3 Likes

@pablo11 , Thanks for getting all this setup and uploading the firmwares. I see my Rollme has the v1.2 on it now. Do you have any info on the updated v1.4?
So far I’m liking the Rollme although I have found it is a bit less responsive to taps and more difficult to scroll in some apps than the Kospet Prime. But I really like the camera improvement over the Kospet. Both excellent watches!

Since I rooted my Rollme S08 I would offer my Magisk modifed boot but I’m not sure if the TWRP backup of boot.emmc.win is the same as boot.img. I was looking around with google and most of what I found say it is the same thing just renamed. For those who want root access it would just make it a bit easier if the TWRP boot backup can be used in SP Flash tool.

I notice that although the boot.img in v1.2 and v1.4 are the same size they have a different MD5 checksum. So for now I could only suggest using my rooted boot on v1.2 if as mentioned above it is the same as the TWRP version.

Just take the boot image from 1.4 and patch it with magisk on a mobile phone or something…
Once you have patched it you can use it with the same twrp

Thanks for uploading the new firmware! I installed the v 1.4 firmware you posted on my S08, and unfortunately it is not working well. The most obvious problem is that the buzzer is activating frequently and erratically when using most apps. Network activities also seem slower. Is there any way to revert to stock firmware? I have access to another (unmodified) Rollme S08.

Can you please share differences between 1.2 and 1.4? What is advantage of flashing? Am assuming BT calling still a no as this is still Android 7? Thanks

The other previous firmware is also available in the firmware thread.
Just flash back.
Did you factory reset after flashing?

I have not been given any change log and of course BT calling is not working in A 7.1.1.

Three differences I have noticed so far:

  1. New stock watchfaces (some quite nice)
  2. Four brightness settings now instead of three in quick controls
  3. New charging screen when watch is docked
1 Like

So that is the stock firmware in the thread? I wasn’t sure whether these were the official firmware or a modified version.

I didn’t try a factory reset, but after just a regular reset, the problems seem to have stopped for now. I’ll let you know if I run into more.

@meta Yep, the firmware are stock.
We work directly with the brand
Any other packages are up to you if you need them or not :+1:

Great, thanks for the clarification!

With 1.4 all my animated watchfaces stopped working :pensive:

After you updated did you factory reset the watch ? Its really important we know this . Thanks

2 Likes

Yes I did, 2 times and still not working

Did you try flash back to earlier version?

1 Like

Yes I did and watchfaces worked fin without any problem. But I feel 1.4 it’s smaller scrolling.

I have experience of slow scrolling with version 1.4
I have given the feedback to the firmware team.
So are you having trouble using watch faces with 1.4? Correct?

Just the animated ones . They work at fine on the 1.2 version

1 Like

Yep that’s what I thought.
Thanks for the confirmation :+1:

1 Like