Rollme S08 GPS no sattelite fix

Hi People!
My S08 sees 17 Sattelites but it is not getting any fix. It shows: 0/17 Sattelites in GPS Status.
I have:

  • tested it for hours on a wide field, at multiple days
  • reflashed stock rom 1.4 from this site ( thank you for making it available :slight_smile: )
  • did a firmware reset
    *Tried several GPS fix tutorials for the MTK 6739 (Mobileuncle MTK tools, Engeneering mode etc)

I saw someone already posted a Video about this problem, comparing it to the Kospet.

The watch is rooted again. If somebody has some Ideas where to start digging, I would be very happy to try fixing this problem.
If I can’t find a software solution, I would even dare to open the watch and look for the Antenna. For that case I will share pictures of that event.

Greetings and Thanks to all, have a nice day

I had the same problem after using the watch for 6 months without any problem on gps fix. I tried all the options you mentioned without any luck. Finally I opened the watch and soldered the antenna and sealed it again and everything works fine since then.

1 Like

2 Likes

Good luck!!!

1 Like

How long have you had this ? If it is a hardware issue it should be returned

8 months. Banggood told me that I am out of warranty and they couldn’t replace it. We made a compensation and everything ok!
So, the only option for me was to give it a try.

2 Likes

That was exactly the Picture I was looking for !! Thank you Tan_Laz.
You opened It through the front right? With the little ‘Sucker’ :smile: that came with the watch.
Did you heat it up a little before pulling?

I opened It with a guitar pen from the front side.
I also heated it up, not much.
I tried with my :nail_care:nails with no success hahaha :upside_down_face::slightly_smiling_face:

@Dr_Andy_Vishnu
I have hoped for a Software solution, that would have been the easiest. I bought the watch in September from Aliexpress. You are right. Maybe I should try to ask the seller, but I don’t think I would return it. It takes a lot of time and you can not be sure that the same happens again.
Okay I’ll try this first.

Thank you :+1:

The problem is the firmware is fine . So that wont help . You could try flashing V1.2 which i use then factory reset

@Tan_Laz Okay :+1:, that sounds makeable. What would you suppose for sealing it back? (of course without warranty)

@Dr_Andy_Vishnu :slightly_smiling_face: Funny! thats exactly what I thought as a last try. FW1.2 and reset)

1 Like

Be good to hear your results

I have the same here. But I think it is not a hardware problem. As you use an application and it show 0/17 (like mine), for me my conclusion is that antenna and satellite receiving signal is working. The problem to fix some of the 17 in view in my opinion is related with the software. If the problem is hardware maybe we see 0/0 and not 0/17.
my 2 cents.

Hello Friends!

The Firmware change to 1.2 and factory reset did not solve the GPS problem.

@Tan_Laz I re soldered the contacs. More or less beautiful. :face_with_hand_over_mouth: I really need a flux pen and a smaller hotter iron for the smd size ‘Reflow’. Unfortunately it didnt help. Maybe my soldering iron is not hot enough. What equipment did you use?
The good thing, the watch is still working. :slightly_smiling_face:


I don’t know, if GPS/WIFI/BT is it one Antenna, Wifi and Bluetooth is working, why not GPS…
@mgpiccinini: Yes. That is indeed strange. I thought this is from the downladed A-Gps data.
But sometimes just for a millisecond (when changing between apps) I looked like I got a short lock.

It looks like this:
[HELP][GPS related Problem] MTK 6753 - huge drop in no. of sattelites in navi apps - | XDA Developers Forums (xda-developers.com)

Thank you all for your interest, have a nice week! :sunny: