Official Support thread for LEM14

Open gdrive on your PC. Copy contacs vcf to your Desktop. Then connect your watch via USB cable to your PC and push the contacts to your watch.
Or send the contacts to an email adress, and open this email on your watch.


Thanks… worked… unfortunately they were copied in very simple form just text and ofc if I want to add new contacts with info it will not be synchronized to my google account so I have every new contact to add it both to my pc and my Lem14… for now is … let’s say ok… but still… I didn’t pay for having this trouble…
Let’s hope they will fix this soon or make a firmware with icons pure classic android that everything works standalone

Hi all, Im new to the forum… desperately looking for help.
I received my LEM 14 couple of days ago and Im generally happy with it (only GPS seems not so good, perhaps SW problem, also some issues charging as sometimes it stops at 50 or 60%, unfortunately no charging dock supplied) … BUT I have a BIG ISSUE as I cant connect to Internet via 4G network. To do so I need to set the APN (Access Point Name) but when I got to the option I get the error ‘Access Point Name settings are not available for this user’. As it is a new SIM I tried it on on 2 different Android phones and there I was able to set APN and all worked fine.
I did the steps suggested in other forums for Android phones (turn on Wifi, Turn off data, reboot etc) but nothing worked…
I really don’t know what else I can try…perhaps is the firmware (but I seem to have the latest V1.7_20210121). I really hope someone can help

If you can’t change APN settings Read This - Kospet Products / Kospet Prime 2 - Full Android Watch


How did you get the contacts to sync through Google? I’ve tried to use Google Contacts but the sync option consistently turns off.

It is not possible at the moment. We are waiting for an update. Copy the contacts from google drive manualy and push it to your watch by using USB.

Thank you very much for the answer. Unfortunately it does not work. I tried 2 SIM cards: with the first one I can see the SIM APN but I can’t edit it.
With the second SIM I can see the APN, I can change it, so I enter the one I need, but it can’t be saved.
Normally in Android there should be the option to Add the APN but it’s not there.

This is a big problem as I bought the watch and the new SIM to have Internet access.

Is there anything else I can try? Can LEMFO help to fix the problem?

It does work.
People have been doing this successfully so I suspect that you are doing something wrong.
@droidtrix has written about this several times.


After reading all the comments and suggested solutions for @Mario_H 's problem, I keep thinking of this…


1 Like

Hi Pablo11, well it does not work for me. It might be related to the SIM available in Italy. My mobile phone is dual Sim but I need both SIM for work hence I bought another SIM to use with the Lem14 when I would go running: to summarize;

  • new SIM: Apn gives error (Apn not available for this user)
  • SIM work 1: Italian SIM, Apn found automatically, I can connect to internet. Apn can’t be edited, hence I can’t apply suggested workaround (no option to add/save Apn)
  • SIM work 2: Switzerland SIM, Apn found. As above, it can’t be edited.
    Now I ordered 2 more (travel) SIMs as last chance. If not working I will have waisted more money on top of the cost of the watch.

Just one note on the workaround: Lem14 behaves differentlty than suggested: if SIM card is removed and another inserted while is on, it must be rebooted or it won’t recognize the SIM.

Ill provide an update once I’ll get the 2 new SIM.

Sounds like you have figured it out on your own.

1 Like

Yes, I figured each SIM behaves differently, none allows Apn settings, 1 out of 3 connects to Mobile data, and unfortunately it’s the one I use for work…which I can’t leave in the watch.

By the way am I the only one with battery charging issues? I tried 3 different chargers and it doesn’t charge well. Last night I put to charge at 39% and this morning,after 7 hours of charge, it was at 87%…and it is a good one because often I find it in the morning at 50 or 60%.

It probably means that the watch got disconnected during the night. Bad connection ?

It is curious because the firmware is exactly the same as the firmware that @droidtrix talks about.
The only difference is a few drivers and cosmetics.
I have tested this and the settings can be edited and Sim can be hot swapped if you follow the instructions.
The settings you change are automatically saved if you swipe “back”
I have tested this as well.
I recommend using swipe back and not the back button.

Have you spoken to @droidtrix about this in his thread about APNs?

using the back button saves the changes and swiping from the edge of the screen also saves the changes, but swiping in the middle of the screen does not save the changes, so I would recommend using the button

Quick update: received the first of the 2 new SIMs I ordered. This is a SIM for domotic applications, just bought it to see if I can apply the suggested workaround. Unfortunately still not working.

When I put the new SIM it connects to network and I can see and edit APN but like the others, it can not be saved, back button or swipe back make no difference as APN immediately goes back to the one of the SIM. I also tried to 1) enter APN 2) Remove the SIM while still seeing on the screen the APN settings I just entered (meaning without using Back button or swipe back) 3) put the other SIM… In this case watch does not recognize the SIM.
I tried the process a dozen of times, with Mobile data on or off, WiFi on or off…nothing.
I will get the second new SIM tomorrow, but honestly I don’t expect it will work. In the meantime I managed to spend 4.50 euro to buy Nova Launcher Prime as I found a YouTube video explaining that it could solve the problem… Obviously it didn’t not work.
In my opinion it’s a Firmware thing and it would be good to mention to Lemfo.

I’m discussing with Bangood to return the watch.

Yesterday after trying different SIM back and forth I was able to save APN while using my ‘work SIM’ . Indeed Back button does the trick.
I was very excited to have finally the solution… But as soon on as I put the ‘watch SIM’ I get usual error ‘APN settings not available for this user’.
Considering that ‘work SIM’ works ok on the watch and ‘watch SIM’ works ok on the phone, then it’s just that the Lem14 is not accepting the ‘watch SIM’ (only for AON as for the rest I have connection and can make calls). So I guess there is no solution and besides the watch, I’m stuck with unusable SIM with 2 years abonament.

Update on charging issues. Put it to charge a 23pm last night at 3%, this morning at 4am it was at 46%, as I think something causes the watch to stop charging, perhaps the notifications, I powered it off… This morning at 8am it was 86%.So 9 hours charging does not get to 100%

I suspect that the Sim APN is not compatible if this has happened.
But I can’t be 100 % sure…

The charging issue can be because of a built in protection circuit.
These newer devices are not recommended to be charged all night.

The latest information suggests that charging until full and disconnecting the watch is the better way.

If you have the charging dock you should connect it to a USB power source if charging from empty.

It is designed to be used when the battery reaches around 40% capacity if you are mobile.
If you charge from empty I recommend that you use the cable directly to the watch.
Either way - it is far better to charge until full and then disconnect.
Otherwise it begins the cycle again and I think it is not good for the battery.

It is the same for modern mobile phones.
Overcharging is not a good idea.

Thank you. Is there any way to inform Lemfo and to get the SIM issue fixed via firmware update? I guess I won’t be the only one with the issue.

Regarding the charging issue, that is not the case. I don’t have charging dock, only cable. Now it’s 11am and I got to 94%…it never got to 100%. its been charging 12 hours straight and still no 100%. I’ll see if I can return it.

No, because as I have explained in previous posts - the actual Android 10 APN editing menu requires the Android “navbar” to be able to function as intended.

Given the round screen this has not been possible.
There is a a possible solution being developed at the moment but I could not say if it would be implemented for this model. Or even at all.

If it becomes a possibility I will let everyone know…
But just so you understand - navbar is only available for square screens - so it’s not a simple fix.
I always advise people to use Sim cards that are known to work, for this very reason.

About the charging issue - if the information I have given does not apply to you - then I have no idea.

If you are unsatisfied with the watch then I suggest that you return it.