Need help with Ticwris max s display issues

Hello everyone,
i’m a newbie here so please accept my apologies if i have open this topic in a wrong way… i have a ticwris max s that is not connecting to google play store. thinking that this might be a firmware problem i looked in the ticwris firmware list without reading to all the comments .i basically went and download a firmware that is higher number than what i have. my original firmware was { Ticwris Max s v 1.920201221P } and i downloaded V_2.020200905D and sure enough the screen is unreadable after powering up .its just a bunch of lines now…I would really appreciate any help to get the screen back to normal the google issue can wait. Sorry for the typo errors as i have only the left hand working due to acciident in my previous life.

You must pay attention to the last letter in the firmware. There are different screens for this watch. Glad you wrote down the original firmware. So you need a firmware with the letter “P”.

Try this one:
-TICWRIS_MAX_S_V1.9_20201221_P.rar - Google Drive

Now i dont know how to turn it off so i can flash it wth the V1,9_20201221 . all i see are lines in the display. i been trying to press the two button but no luck.


Maybe i’ll wait for the battery to run out.but i dont know if it will flash wihout battery power because if i remember right it needs to have at least 40% battery life in order to flash.

This is why I didn’t give access to the twrp and patched boot image you asked for.
You need to take some time to understand stuff.
You can flash firmware without having to drain the battery by priming the flash tool and rebooting the watch to make it work.
But you need to research this process before diving in and ending up in a situation like this…
Please take the time to check out how this stuff works.

1 Like

Pablo11, got it working now. i followed your instruction about priming ths flashing tool and it works.thanks a lot for the assistance,

i would appreciate any advice regarding google connectivity problem.



Download a play store updater app and update it manually.
Obviously check network is connected and check your IMEI number is ok.
In watch settings/about watch/Status.
If imei is missing it can cause problems with play services.
Try this anyway and use the play store link in the app.

1 Like

Hello , I have connectivity but not opening google store or google browser .i manage to download a pre loaded apps basket that contain Opera and you tube but it saying it need update and closes again.i tried to open google play store but it says “there is a problem communicating with google servers”. I tried to click updates but it says "error retrieving info from server DF-DFERH-01.i did manage to download an apk file of play services update and updated the system still showing error. I will keep on trying and give updates .
thanks to all for all the inputs it much appreciated…

Try this app:

Update today I manage to go to the link you sent and tried downloading google play services update but "the system is showing that my device is not recognized ". I checked my IMEI and number is there and its there.previously on another site "apkpure"I’m able to download and install google play service update but no change I still cannot open anything related to google that comes with the OS 7.1 . i tried Pablo 11 suggestion also with the google play mobile and downloaded google play update but no luck . Please note I’m using opera browser [the only one working in the device) I will explore some more and update this thread. good morning to all

My advice is to factory reset and if it doesn’t work after that you should flash a different firmware version.
Something is definitely wrong.
You have set the time zone correctly?

Yes I did the factory reset this morning and manage to load updates to google play services via apk but when I check it is still dated dec.-31-2008 as last update. have tried to clear cache and storage of google play and google .and still won’t let me log in to any google apps.With regards to time zone I adjusted the clock to my location time zone GMT+07:00.and for the firmware the device is telling me it is the latest V1.9_20201221. I have a screen shot of google play services update .I

Are you using Wi-Fi or Sim card?
If you are using Wi-Fi can you try a Sim?
Can you share a photo of your time zone settings please?
This makes no sense at all if everything is correct…

I think you will be better off flashing the Kospet Note firmware.

By the way, did you use the firmware upgrade option in the flash tool?
Or download only?
Is this a branded Ticwris or a Kospet Note or a DM101?

I realise I am asking a lot of questions, but unless you are in China - this makes no sense at all… :thinking:

It like you are being blocked.
I would like to see a photo of the error message and the time zone settings and your network connection if possible please.

There must be a reason for this.
I have both Ticwris and K-Note and I have never seen this before.

1 Like

Pablo 11,
i have sim and wifi activated in the phone.i did use the firmware taken from the full androidd watches forum v 1.9 .it is a Ticwris Max s and it came with free screen protection x3 and free extra bracelet band and extra long screws for the bracelet and i just bought it last month and it arrive this week.Like what you said it is like it is blocked, i will be posting a lot of pics please bear with me.

Pictures as follows first group the google play store update fo

second batch of pics for the time zone

Pablo11 ,
Apologies for the clutter… yes i did try with the sim first but i could not connect . the sim is from my phone and it has connectivity but i could not connect so i switch to wifi.i will try to reset the device again and start from the beginning. Thanks for the patience.


this is the sim status at 4G connection.

Turn Wi-Fi off.
Use cell data only and the correct details will be pulled from the cell tower.
Set time zone correctly and set back to “automatic” your photo shows automatic is not enabled.
Now reboot the watch and check play store again.

Have you managed to sign into google at all yet?
I doubt this is possible while this problem is happening.

Just so you know, this is not a “watch” problem.
It’s a configuration problem and likely caused by a mix of time zone, outdated play services and outdated play store libraries.

I change it now to Auto then restart the device it is still the same, no connection with play store and cant sign in to you tube.