Need help. Tried to root LEMFO LEMT now it won't work

As the title says I tried to root my lemt and it would only boot into TWRP Recovery. Flashed different roms and it would start up without picture, tried again and got the white lines, tried again and bootloop, tried again and now it starts up normally but touch screen not responding. The buttons work but if I let the screen time out it shuts off. One tap of the power button it turns on and boots up normally, but again touch screen not responding. Not sure what I’m doing wrong. I need help please.

There are 4 screens for this watch. therefore there are also different firmwares. You can find the latest firmwares here. Try all 4. One of them will work:
-Black White Stripes Issues after Re-Flashing

Please use “firmware upgrade” instead of “download only”.


I will try this thanks

So I got the 3rd one to work. Thank you so much! So I’m now running ticwris on my Lemt, which is what I wanted in the first place. So that was the easy part… I lost my original back up. So as you can guess I do not have the correct IMEI. I have the box it came in with the correct IMEI but I don’t know if that even mean jack squat. Suggestions?

The IMEI is not changed by installing new firmware.


Well I did kinda wipe everything. At one point only had TWRP no OS. All I know is that the one Showing on my LEMT doesn’t match the one it came with on the box anymore. I haven’t hooked it up yet but I want to and wanna make sure it’s going to work first.

Why don’t you test it out? It will not explode.


I don’t want to invest in a new phone number and data plan and not have a properly functioning device to use it with.

I suspect that the IMEI numbers on the box and on your device were never identical. Anyway, borrow a SIM from a friend and give it a try. I am sure it will work.

1 Like