Misirun Z35 watch stuck on Android logo

Hi guys please help me :pleading_face: my misirun z35 stuck on Android logo please help me what I do for fix please help me :pleading_face:

Hi please help me my is stuck on Android logo what I do

This is a A7.1.1 watch that we do not support so finding firmware for you to flash it will be difficult . Have you tried holding down both buttons together and forcing a reboot ?

Also you could carefully open up the batch and disconnect the battery and then reconnect it


If you don’t want to open it, you can also wait until it is completely empty and goes out. Then load it completely and then start the watch.


What did you do before ot happened? Did you do something with watchfaces or installed any new apps?

Yes I installed new app , please help me

Have you already tried what I suggested? waiting for the watch to drain completely and turn off? Then fully charge and restart when the watch is charged?

1 Like

Do as @G1NT0N1C said wait till the battery drains off and charge it completely and then turn It on if it still stuck on logo , youll have no option but to flash it, if im not mistaken it is the same as lem 15. @pablo11 right?

Same board but different screen.
The firmware is only possible to get if I have the details of the exact version that came installed on the watch.
There are about 20 different Z35 models and most of them have different screens, different ram and storage etc.

We don’t support this model, so it is slightly more difficult to get the firmware for it.


@pablo11 Maybe a solution would be to use one of the z35 firmwares and only flash user data? The app causing the problem should be deleted like this.

This watch stuck on Android logo misirun z35

A photo of the box would be more helpful. Here you should find a sticker with information about your watch.

No any stickers all black , i ordered from alibaba, and don’t know how to flash firmware and don’t have firmware for flash

Please answer my question: have you tried waiting for the watch to drain completely and turn off? Then fully charge and restart when the watch is charged?
I need the answer as this would be the easiest solution. If it works, go to settings and remove the app.
Which app is it?

Thanks @G1NT0N1C
I was wondering the same thing.
Anyway, I am happy to help with the firmware but I need to know the details of the original version.
As I said before @Raka there are many different Z35 models and many different combinations of configuration.
It is possible to flash the user data partition only… But the risk with A10 and above, is the key used to encrypt the userdata.

It is far easier to retrieve the original firmware version.

Good luck @Raka


You are right, it’s an A10 device. I thought it’s A7.

1 Like

I try but not working

After draining completely, after putting it on charge, it starts but again it gets stuck on the Android logo.

That’s just the sales blurb…
I need the firmware build version details.