Microwear H8 - lack of google play store - Unsupported here.!

Do you have an H8?
How can I install Google play store on the Microwear H8?
It comes without. What other alternatives are there?

I checked the Microwear web site for the H8 and it says it has Play Store access. It is running Android 7.1 and all 7.0↑ watches I’ve used have a Play Store App. Is it possible the app is available but you don’t recognize the icon? Sometimes they use a different icon to show the Play Store than what you may be use to seeing. If not you can try to download the app from apk.pure and install it on the watch.


Hi Jonathan,
Thanks for your prompt reply!
There is an APP store but it only offers 4 apps
Facebook, Twitter, Whatsapp & Youtube
I tried installing whatsapp & youtube from there youtube doesn’t run after installation.
I’ve used APK.Pure for downloading apps. Some work OK some don’t.
For some reason when I try to download & install playstore it fails (I tried various versions)
Do you have a recommendation for which version I should be using?

Do you have google play services or any other Google-y thing in the app list? I don’t know if you have twrp on that watch (or if it’s even available), but if you have you could try flashing gapps on it. Or you could try reflashing the original firmware. The appstore that comes with the watch is a joke, idk why they even bother to make one and put it xD.
For an alternative app store you could try Aptoide, it has an option to show only the apps that are compatible

That App Store app is added by the developer and not intended to replace the Play Store. Got my curiosity up. Have you looked through the App list, Settings “uninstall applicatons” for example and see if Google play store is listed there?
Have you tried downloading the apps from your computer direct to the watch or to another device (phone) using App Backup & Restore and then transfer them to the watch. That is generally how I load apps into my watch anyway. Keep them in a file on the watch called “Apps” and that way they are easier to reload if necessary. No internet connection required.
I believe U Tube recently updated their system and the old app no longer works. You just might need to update it.

Hi Jonathan,
I have “google play store”, “google play services” and “youTube” in the “uninstall list” but none of them work. (this is from one of the versions which managed to install and not run.
I had instances/versions where they didn’t install at all.
In most cases, I download the APK to my PC, transfer it to the watch (via USB) and “click” on the APK for installation.

You could do a factory reset but assuming the watch has had this problem since the beginning that probably wouldn’t help but won’t hurt. If no change try flashing the firmware. Have you contacted Microwear about this issue?

Will give gapps & aptoid a try

It took me some time to tweak the watch and get it to work with my cell provider. so I’m trying to refrain from resetting it.
Microwear haven’t responded (I tried various contact people on their site)

1 Like

Hi evaryone rately in need for Microwear H8 smartwatch firmware. Sellers are playing dumb, official site is down, techsupport is dead. Please, any owners of this watch - make a backup trough flashtool. Microwear H5 firmware is partially compatible, but with ruined screen. So at least i need boot.img from H8 please help me