Lokmat X360 and/or Lok02 firmware?

Does anyone have / can anyone get the Lokmat X360 firmware (dual camera 3 gb / 32 gb)? (or maybe even the LoK02 firmware since it’s also dual but only 1/16)

As I describe in this post, mine was bricked while evaluating it for a YouTube review and Lokmat will not respond to my request for firmware.

NOTE - it is indeed possible to flash the Lokmat X360 with Zeblaze Thor 4 stock firmware found elsewhere on this forum. However, the second camera will not be operational at all, which is a distinct feature of this watch. And Zeblaze Dual firmware does NOT work (black screen). Lokmat users would want firmware that makes both cameras operational and preferably comes with Lokmat branding instead of Zeblaze.

I can get this firmware for you if you give me the details of the exact version you had on the watch before you start flashing.

Or I can just get the Lokmat X360 latest version if you are confident that it is the correct one?

Pablo, I would extremely appreciate it.
Because the watch died so early, I only had taken a brief look at the About Watch and I believe it was 20190529 but it could have been 20190526 or something else. I really wish I knew.

I would be willing to try any X360 firmware (maybe earlier is better?) and willing to keep the watch if I could just get the firmware and reset it. It has been nearly a week of asking every day, and their “support” on their official store won’t give it to me and wants me to return the watch, saying it had been “soaked in water” although it was only a normal run for testing the fitness app for my YouTube review.

@pablo11 Thanks again but just curious how long it usually takes to get firmware. I supposedly have about 4 days remaining to decide whether to return the watch and would love to try some Lokmat X360 firmware to see if I can restore it.

Well, the problem I have is that there are many different firmware versions for this model. Flashing the wrong one could be a real problem.

When it comes to firmware the date is not important…
The important stuff is the information along side of the date.
This info has the screen type… etc etc…

Anyway, if want to try a generic type of firmware - what comes close to describing your watch.?
Zeblaze -
Thor 4
Thor 4 Pro
Thor 4 Dual


@pablo11 As I mentioned in the first post, the latest Zeblaze Thor 4 from elsewhere on this forum [the most recent upload WITHOUT the brightness bug] works perfectly. Even though the Zeblaze is 1/16, the 3/32 is recognized. Except, unfortunately this firmware doesn’t enable the selfie cam, which is one of the main reasons to have this watch. I can’t figure out any Android OS or software method to recognize the selfie cam.

The Zeblaze Thor 4 Dual doesn’t work at all, the screen doesn’t display even though the buttons cause vibration.

Ideally it would be like the Zeblaze Thor 4 except the front camera would have the same resolution and picture abilities as the rear (and ideally course the Lokmat animation). :smiley:

@pablo11 know you guys are busy. sent a donation. I have never been able to find any Lokmat firmware, so when you said you could get it, I would be willing to try anything, and it would probably be useful to other Lokmat owners also.
I really think the latest for the X360 specifically would work because 0529 would have been a very new batch. But anything for the X360, or even an earlier Lokmat with dual camera like the 02, would be helpful. Please let me know if this is doable before July 6th because I must return the watch then.

This was the best I could get without more info. I hope it works https://drive.google.com/file/d/1whiI9d1J8DXp0DVV8K0m65bndgf4NZLK/view?usp=sharing
Sorry if it’s too late - it took a long time to get it and then my slow upload.


Pablo, thank you so much! I was able to flash the watch with this firmware and get it working, including both cameras, and I haven’t found any problems yet. I’m thrilled that the folks at this site manage to get things done even when the manufacturers can’t support their product. :slight_smile:

I’m really happy to hear that we have been able to help.
It’s not that these brands don’t want to help, it’s just something that they are not good at and that’s why we are here.
I’m really sorry that it took a little while to get this for you but we do our best.
We have full time day jobs and we do this as a hobby, we don’t get paid for it.
By the way, thank you for your donation. This is how we exist :slight_smile:


Is that firmware sufficient for the Janus also? Seems to be the same device.

Personally, I would say no.

The Thor Dual was almost the same but didn’t work.

If you need firmware for your watch please post the exact version that you have now and I will see if there is any newer version.

Is there any reason to flash the Janus watch? I mean are you having problems with it?

There is nothing wrong with the watch per se. I just feel like I could squeeze more battery life out of it if rooted and optimized. Its fine if there are no notifications and I’m not using internet, but simply listening spotify at the gym can drain the battery almost 60%.

Also, I’d just like to have a copy of the firmware. Since it was purchased on Ebay, there really isn’t a place I can go to download it.

Baseband = Moly.LR12A.R2.MP.V5.23.P10
BUILD Number = xy_smartwatch_Janus_b_20190627

I’ll see what I can do.

Here is the stock firmware for the Janus model https://drive.google.com/file/d/1gzSzcpj0Q5Hof9v2BuMie3PeAk8_4Xsf/view?usp=sharing


Dear help revive the clock X-360 (361) 3/32g, firmware Main band = Moly.LR12A.R2.MP.V5.23.P10
Build number = xy_smartwatch_Janus_b_20190627 revived the watch, but the lower part does not respond to the sensor and the middle one time, it feels like the screen resolution is different, but I can’t find out the native firmware, please help.Here is a link to such watch on aliexpress.https://aliexpress.ru/item/1005003605071681.html?gatewayAdapt=glo2rus&pdp_npi=2%40dis!USD!US%20%24281.00!US%20%24266.95!!!!!%4021165f1216543295086524923e3e1b!12000026464489487!im&sku_id=12000026464489486

Have you tried a factory reset ?

something is wrong with the screen calibration, or firmware for 400x400, but I have 320x320

Yes, I tried it, it doesn’t help. Also, the screen control is confused from left to right, more precisely, if from the middle of the screen to the right or left, it’s normal. firmware and everything is broken

@Александр_Мясоедов Let me know exactly what the original firmware was or find me the details of your original purchase on the Web.

I will see what I can do about the firmware but it is a very old model and it may not be easy to find.
I see the model from the link you gave.
But I really need the firmware details… The original firmware

1 Like