Lemfo lemt charged but screen goes off on reaching home screen

It worked well for 5-6 month. Then I did not used it for few days in lockdown last year

In July 2020, I tried to turn it on . But it did not turned on

After few months I presses the power button for 10-15 seconds. It turned on but screen flickered and got turned off after reaching home screen.

Tried many times in last 1 year, but situation remain:-

  1. The battery chargers 100%.
  2. To start, need to press button for 10-15 seconds
  3. It boots and reaches home screen
  4. Before I can use any function, screen flickers and it gets turned off.

Any idea, what can be wrong with it?

Most likely the battery …


First thing to try is flash the fw.


Select firmware upgrade :+1: before flashing

@Dr_Andy_Vishnu , @Eric_Crochemore Where I can get Firmware, Flash Tool and USB Driver for Lemfo LemT?

Firmware can be found on this forum using the search function

I flash with DM100_LEMT_V1.4_20190919_P. Still same problem persists.

I am spending so much time after 16-17 months so I am understanding it’s problem better.

So the actual problem is: When it starts, its touch is unresponsive. So, after starting, when I touch anything, no function is performed. Once screen gets turned off, pressing the red button cannot lit the screen back. To restart the watch, I need to long press the black button (the upper one).

When the watch get turned on, I can only operate watch by black button (upper button). As soon as I press red button, the screen goes off and cannot turned on again by any of button, but again I need to long press the black button to be able to restart the watch.

So in conclusion:
On turning on, touch is unresponsive
Buttons are working, but they don’t work as they should. I mean when pressing red button can turn the screen off, re-pressing it should turn it on also. but it does not.

Neither touch or watch is damaged. What can we do about this?