LEM14 failures after water exposure

Hi all, i have been using the LEM14 in water for the past 2 weeks (for simple pool and sea sessions) and first my back button said bye bye but now, probably due to additional HW failures, if rebooted, it goes into a sort of diagnostic mode with chinese symbols in green mixed with HW checks in regular fonts i can’t fully read due to screen not fitting properly.
It seems the mic is also failing.

To get out of this, i keep the power button pressed (this button survived yeah!) and it goes off again and apparently i am able to boot it ok the second time.
I need to repeat all of the above whether i reboot or power off the watch.

Any idea of what might be causing this? A HW fail that forces the watch into that at boot? I have the FAW firmware.

Adding a few pictures of the boot session…

Needless to say this is far far far from being an IP68 - obviously i was not expecting anything better from such a device but still i gave it a try in real life without paying attention to clean it up from salt or not pressing buttons unless completely dry.

If that’s what you expected, why did you do it?


@G1NT0N1C - Not sure that answer my request for support, however i will try to satisfy your curiosity. I am a diabetic person, and the only reason for me to even bother buying chinese devices from non reputable brands is that i can have it paired directly with my bluetooth glucose sensor and be free from carrying a mobile phone on me in water around my neck or waist. Also i moderate a community of diabetic people and i was testing this for them.
Managing diabetes means reducing the presence of any sort of stress factor, including caring about a cheap watch while on vacation that is supposed to be IP68 (like my right hand fitbit versa 2 of 5 years and many deep dives…).
So i tried my luck and it worked for almost 3 weeks straight :stuck_out_tongue: until it failed me as expected (well as youtube videos made me expect!).


OK, fair enough. Even if the result, as you rightly remarked, was to be expected. I agree with you though: it shouldn’t be sold as IP68 if it’s not IP68. Rescuing your watch will be difficult. If salt water is causing the problem, it’s almost hopeless. But hey, let’s try: Turn it off. Then open the sim tray and put it in a bag with rice for a few days. Best on a sunny windowsill. We need to get the moisture out first, then we’ll see.


Thanks! Tried the rice trick for a little while but i’ll give it another try. As you say i also believe it’s hopeless!