LEM12 Pro A10 Official Support

i also have this problem. this message keeps flashing on and off and it wont go away. I’m panicking.

the “bad state” message comes up and the watch reboots after 5 seconds back to the same message over and over. now it wont even communicate with my pc. that v6 update messed me up.

all i did was. tried to update the firmware via the data cable. now this message turns on and off and the watch wont communicate with my pc. what should i do?

1st, keep cool. No need to panic. :wink:
Try to power off by press and hold both buttons. Then try to flash the original firmware by using the flashtool.

Please use “firmware update” instead of “download only”.

ok, hear what i did. the battery eventually died, as it kept turning off and on. restarted my pc, reinstalled the driver, set up the flash tool with the stock rom. plugged in the watch and it flashed with the stock rom. so its up and running again. this time, im taking the update wirelessly now.


Good to hear that you solved it. In fact, it’s hard to hardbrick these watches…

1 Like

i stayed up all night trying to reverse the problem. oh yeah, before i tried flashing the stock rom, i ran the auto format. that helped

smh still no resolve with the APN. im thinking, maybe its the network. i put the sim in, restart the watch, went into network, mobile network, scrolled down to Access Point Names and that came up(in the pic). still nothing. because of that, my watch just been on a shelf for the last 4 months. to me that was the most important feature i was interested in and it turns out, it cant work for me. got excited when i heard their was a firmware update, i hoped they patched the problem

You need to use the FAW International firmware to change the APN.
As long as this is a LEM 12 pro Android 10 watch.
You can just drop the zip file to your watch storage and then flash it with the built-in OTA app

wow, where can i get that?

Here… Please read the top post carefully :+1:

1 Like

thats awsome. im gonna try the v1.1

You don’t need the flashtool. As @pablo11 mentionend: Read the top post carefully.

1 Like

haha. yeah i noticed. just sent the file to the watch. searching for the OTA app now

You don’t need any. The whole procedure is described in the post.

1 Like

awesome. you guys are superb. keep up the good work. my faith has been restored lol


Is it possible to uninstall application MUSIC or disable it somehow?

Maybe this is what you are looking for?
-How to delete installed Apps on Android 10

1 Like

probably yes. I apologize for the new topic but I don’t know the language of the forum so it’s bad to look for. Thank you