KW88 - USB Device Not Recognised in Win 10

Hi Team
Desperate for help.
Watch working fine up to a few weeks ago. No issues about connecting to phone, charging or navigation.
The only thing that has happened is the device is no longer recognised by windows 10 on multiple machines and with 2 different cables! (An Unknown Device - Device Descriptor Request Failed in device manager)
I have reinstalled drivers for MTP, USB hubs, USB drivers and followed the forum guide but still no go.
I use it mainly for the watch faces (as a regular watch replacement) and have no other extra apps installed and did not root. I have factory re-set 3-4 times already and still nothing.
Now I cannot access the watch through windows so am a little stuck.
Has anyone else had the same issue? Any thoughts or solutions? Any way I can get it to work around windows issue?
Any help will be great.

I have a similar problem, I connect the watch to my laptop through the USB port and the watch is found by Win 10 but it says no files found. I know there are files on the watch because I can see them with the watch. Anyone have any ideas?

@Dick_Storer Connect with PC, go to - settings - connect - and choose transfer data.

Transfer data is not an option for me.

Hi Shane, have you ever been able to fix the problem?
(or anyone else fix it?)
I have the exact same issue.
It says on the Dev Manager that Windows has stopped this device because it has reported problems (code 43)
And have tried it on other Computers with different Windows versions, as well as several cables.
It worked fine till last week.


Many years ago i had a similar issue with the same watch. I reinstalled drivers and it worked again ( for a while anyway )


Hi mangusta,
Sadly never did retry after multiple fails so stopped using the watch.
I have rebuilt my pc since but never got round to reusing the watch (I think my strap also fell apart on both sides so did not want to throw good money after bad.
Considering a new purchase…

Hi Shane,
Thanks for letting me know, I am going to keep trying, at least for awhile.
I have just recently ordered a new strap (as one side had a crack half way across it).
At least apart from the USB problem it still works OK.
And I had created some screens with a De Tomaso Mangusta theme (early 70’s Italian sports car).
I have had one for 20 odd years now.
I would be interested to know what other watch you are considering?
Thanks again

Hello Dr Andy,
I have not been using mine for quite awhile.
So could you please tell me where to download the Drivers, and what to install.
(I can’t remember what I did originally)
Many Thanks


1 Like

You can go into Windows device manager and look for any device showing issue.
Normally with an exclamation mark against it.

Sometimes it is as easy as right clicking on the problem device and choose “update driver” and then select an MTP driver (already on your PC and you should see a list of options when you click on “choose from available drivers”) and test it.

In the days of Android 5.1 this usually works.
If not, then you can install the MTK driver package.

1 Like