Kronos Blades Genesis earbuds

Just got the Genisis smart watch kit. I’m having a problem pairing both earbuds. Only the right ear bud is pairing and has sound. The left is flashing green rapidly and no sound. Anyone have a solution?

Hi . Do this help your query

2 Likes

You pair with the right ear bud and then hold the button on the left ear plug and it will pair with the right.

1 Like

I asked Jason himself about this and he pointed me in this direction to seek help.

I’ve had my Genesis for a few days now and while I do absolutely love what it has the potential to be, I’m having some issues which are making it borderline unusable for me. I’ve reset and checked for updates, but the issues are still present.

  1. Reception . When used as a standalone device with a SIM inserted the reception is so weak I get no reception at all indoors and barely get enough reception to send an SMS outdoors in the wide open. As per the specs it should be compatible with Band 20 and every other device I’ve ever used gets full, clear reception here.
  2. Fitness Tracking . The passive Step and Distance tracking / recording seems to work perfectly well and seems quite accurate, but when I actually use one of the fitness tracking modes such as Outdoor Walk or Outdoor Run, it’s hit or miss whether it works accurately or not. Sometimes it worked fine, other times I’ve taken 20 paces and it’s recording that I’ve travelled 14km already at a pace of 200kph (for example).
  3. Bluetooth . Multiple times now I’ve paired the watch with the included earbuds to go for a walk and listen to music, but almost every time the audio breaks up horribly just standing / walking normally with bare arms, no sleeves and nothing blocking or interfering with the watch and buds. Only when I bring the watch up to my face maybe 12 inches from the earbuds would the audio play smoothly, suggesting an incredibly weak Bluetooth antenna or signal. Rather than a Bluetooth 4.0 range of around 200ft this is barely managing 2ft. The first two are frustrating, but I could live with them as I wouldn’t use them too regularly, though obviously the reception issue could become important if I ever chose to leave my phone behind and rely on the watch for communication during a trip. The issues I’m having with the Bluetooth are ruining it for me though as my main desire / use for the device is to pair it with the included earbuds and have a great, large capacity music player with me all the time without needing my phone. The same occurs whether it’s tethered to the phone or not or whether I have the phone with me or not.

The network and Bluetooth antennas in my Genesis seem to be incredibly weak or perhaps faulty (?) making the device essentially unusable for me, so I’m wondering if there are any similar issues being reported, or if there are any software updates which may remedy these issues? If not I need to figure out the companies stance on return and refund, if that’s even possible.
(The earbuds are fine. I tested them with other devices)

Thanks!

Hi . Firstly before we start did you do a full reset before you started using the watch ? This is important . If so unpair the earbuds , full factory reset and try again .

The watch itself should work on all listed bands but you must note that you will not get a signal inside as good as you will with a phone ( due to size ) . This applies to all watches , not just the genesis . This is not a fault . Outside the same but this should be less of a issue . You should be able to make calls , texts etc . Again a full reset may help

The stock fitness app is okay but not perfect . Again this is the same on all watches . I would suggest you use this . Its much more accurate and uses the in built heart rate monitor . Make sure you activate under special permissions - sensors on the watch .

As for the bluetooth i hope the full reset will rectify this . Again though you will not have the range a phone has ( due to size ) but it should work after unpair - pair . We have had no reports of signal issues . There are no OTA updates as yet as not required . I hope this helps

Dropouts while walking is a problem I’ve had with a number of watches and earbuds, including the Genesis/TidyBuds combo. For some reason indoors it is usually not as bad - maybe reflection off surfaces reinforces the signal?

I just got the Blitzwolf FYE-8 buds and they are much better at maintaining connection than the others I’ve tried.

2 Likes

Dropouts can happen if you have a high CPU usage on your watch. Also, even if i have not found this problem with the watch, i know that my Huawei phone is not capable of using BT and wifi at the same time, if i pair the BT earbuds on my phone, i can’t connect to WIFI anymore. But once again, on the watch i have no problem listening to music and navigating with WIFI on the web.

2 Likes

Another problem can be interference.
So many BT devices around when you are walking down the street…
It’s not supposed to make a difference but I have noticed that it does… No matter what device I’m using…
Just my opinion.

1 Like

Maybe it also depends on the music player - I mainly use Google Play Music. Regardless, now that I have earbuds that work for me I’m happy.

1 Like

You’re right. It does seem to be the buds. I borrowed a pair of Xiaomi Dots to try and so far on a couple of quick tests they’ve been rock solid.
If you’ve experienced similar issues with these buds, I wonder how many others have, too. You’d think such a thing would be thoroughly tested before sending something out as a package.

Hi there. Thanks very much for the prompt response.
I reset the device as soon as I got it as per the advice from a youtube video. Then again after discovering the issue, and again today after you suggested it.
The bluetooth / earbud issue again reared its head immediately. The Tidybuds and Genesis can’t even maintain a bluetooth signal from my ears to my wrist. I don’t expect the same range as a phone, but that’s shocking and not fit for purpose.

HOWEVER. I managed to borrow a pair of Xiaomi Mi Dot bluetooth earbuds and on a couple of quick tests indoor and out, so far they’ve been perfect and maintain a strong connection with the watch from 20 or 30 feet away. I need to do a few more test runs inside and out before being comfortable with my conclusion, but it seems the issue is with the Tidybuds, not the Genesis.

Luckily that’s not something I’m concerned about. I’m in the Highlands of Scotland and when I’m out walking it’s generally in the middle of nowhere. I also didn’t even have my phone on me when trying these so that wasn’t an issue either.

To my mind the ear buds supplied are about as good as what you would expect to get such as when a pair of corded earbuds were supplied with your mp3 player or phone. i.e. they are just good enough to do the job but not really of any high standard of quality. For something decent you need to fork out some extra money on Bose or similar… Anyway, I gave my buds a test run yesterday when I went out for a walk; listened to some music and took a couple calls. Everything worked but I did experience some minor dropout when I turned my head sometimes, perhaps blocking some signal with my head or body? And sound quality is reasonable but nothing special, I think I need to change the rubber tip things though as they are a little too small for my liking. Personally, I think as a bonus addition to the watch package and also with the extra watch bands (which I think are excellent compared to what I have experienced from Zeblaze) I am very happy with my purchase so far. My only worries are with the durability of the product as this is what has let down Zeblaze products for me.

2 Likes

when I have the Kronos earbuds connected and playmusic from my watch it works and sounds great.

But, when I connect the earbuds AND my phone w/WiiWatch2 app the music drops in and out?

How can I fix this?

FYI, I have no sim card and the watch is also connected to my wifi5g wireless network.

It also happen to me as well. Another problem I encounter is the Kronos earbuds microphone is too soft and when I use it to make call, the receiving parties always complain they can hardly hear me because it is very soft. Anyone know if there is there a solution to this issue?

i had a similar connection problem with my Kospet Prime, but i didn’t test the music playback field…Whenever i connected both my phone (via Watchdroid app) and my earbuds to the watch, i had many disconnections…So i decided to connect the earbuds to the phone and no problem since then. Maybe these watches can’t handle two bluetooth connections properly.

On my watch I run floating toucher app that has some setting functions in it. When using the volume setting on the app I was able to turn up the microphone volume. It was only turned 3/4s the way up. You might be able to get to that setting another way but that’s how I got to it.

Thank you Thomas - I will check it out.

I’ve found that connected to my galaxy note the volume is extremely low.

  1. And then I went to developer settings>networking>disable absolute volume
    Turned that on

  2. Then I went to settings>connections>Bluetooth>advanced

Turn on media volume sync.

That instantly made the tidy buds jump from sounding like they were playing at 50% to full volume as soon as I touched the volume slider.

That lasted until I disconnected the headphones. The setting had been turned off and greyed out ever since then.

Any ideas?

*Update

Posting that put this issue back on my mind so after some searching I found a complete set of instructions and am currently enjoying much louder volume. :wink:

Go to settings, scroll down, open about phone, open software information, press consecutivly on the build number button (like 10 times or so) until you get a message saying you have successfully unlocked developer options, go back to settings, open Bluetooth options in the connections section, unpair all of your audio outputting devices, go to settings main menu, scroll down, open developer options, scroll down until you find “disable absolute volume”, put it on the active state (on), pair your wanted Bluetooth audio device(s) back and enjoy!!

For those who need an explanation: This unsynchronises the sound volume of your phone from your Bluetooth audio device’s audio volume, so you get more control. This fixes the software side of the “sound is way too high or way too low” problem

1 Like