Kospet Prime battery replacement

My Kospet Prime watch kept re-booting during the night, when I checked it the watch was quite hot so I powered it off. The next morning it would not boot up so I assumed it was a battery failure. I tried a local repair shop but they would not fit a battery. I have now purchased a replacement battery, can anyone give me instructions on how to fit it.

What happens when you put it on charge . Does the whole watch remain dead ? Or does the charge icon light up

No charging light comes on the whole watch remains dead. I know that the charging unit is OK because my wife also has a Kospet Prime and that charges OK

Hopefully the watch hasnt been fried . The continued charging might have ruined the watch . However i would try flashing the firmware

Flashing tutorial 2020 - Google Drive

1 Like

The watch was not on charge when it kept re-booting, and as it was quite hot I powered it off. It was a few hours later when I tried to re-boot it. As there was no life to it I assumed that the re-booting had flattened the battery, so I then put it on charge, but after an hour on charge there was still no life in it.
I can try flashing the firmware across, but failing that can you tell me how to fit the new battery to try it.

I’ll be honest i havent changed a battery in the prime but i must warn you . There is a fragile connector inside the prime that is easy to damage and hard to reconnect . I know this because i had the prime watch that Smartwatch ticks used in a teardown video . My watch became unrepairable due to this damaged cable . It maybe worth you watching his " prime teardown video "

1 Like

Thanks for the E-mail. I have seen this one, but it only goes as far as opening the back of the watch and not removing the battery. Is there a video which shows the battery removal/replacement ?
Also with regard to the flash transfer, I seem to have a problem installing the USB Driver, Every time I select the "Install USB driver it comes up with a message “Install USB driver successfully” and then exit. When I check to see if it has installed the Driver there is no sign of it. Is this because I am running Windows 10 on 64bit, as the driver looks as though it is for Windows 7.

Have you tried flashing regardless of the driver ? I’m running windows 10 and didnt need to install . As for video its a no unless there is one on youtube

1 Like

Hi Dr Andy
I tried flashing the software, using the flash tool. The MT6735 android scatter file loads OK but when I select “download” it goes no further and does not download. Can you advise
Thanks

when you press download the watch should not be connected to the pc an it should be turned off. connect it after you press download. and it’s supposed to be MT6739 not MT6735

2 Likes

Sorry, the scatter file was MT6739 not MT6735 as I previously typed. The scatter file loads OK and the label on LH side changes from MediaTek to MT6739 and it shows the image files in the panel. I then select download and the download button goes fainter to show that download has been selected but nothing happens, and I have to select stop. I have tried it with the watch base connected to the USB port but without the watch connected. i have tried it with the watch on the base and also tried it without any connection to the USB port. but it makes no difference

I personally carry out the steps up to the click on the download button before I connect the watch. Only then do i connect the watch to the computer. Important: The watch MUST be switched off. For me it works best when the USB cable is connected last.

1 Like

Hi I have now managed to replace the battery in my Kospet Prime watch. I did it by removing the back, lifting the battery and gently eased the terminal block with the ribbon cable connected to the back of the watch and the ribbon cable to the battery. I then gently eased the battery ribbon cable where it is glued to the terminal block and then removed the battery. The new battery was installed by connecting the battery ribbon cable to the terminal block in the body of the watch and then re connected the watch back ribbon cable terminal block. The back of the watch was then screwed back on ant the watch booted up and worked OK. The only problem I have got is the battery will not charge from the charging dock, which may have been the original problem. The charging dock is OK as my other Kospet Prime charges on it. I have cleaned the terminals on the back of the watch but it still does not charge, can you advise?

could you first try to do a readback of both watches with sp flash tools. just set it to read a couple of kB at the beginning of the EMMC_USER region. If it goes as expected, the good watch should finish the readback without any issue, while the bad one should see no progress just as it did for the flashing.

If that went as expected, you could now, if it’s not too difficult, try to switch out the back cover with the back cover from the other prime and see if it will charge then

Thanks for your advise, however I have left the watch overnight with the power off and this morning the new battery was discharged so there is obviously something which is draining the battery even with the power off, I am reluctant to switch the watch back with my other watch in case it causes problems with that one. I guess it is the end of the road for this watch which is very disappointing seeing that it is less than 18months old. Thanks for all your help anyway

Where did you get a spare battery for the Prime??

From HX-Tech Factory Store on Aliexpress

1 Like