Kospet prime 2 watch droid

I bought the prime 2 well I wasn’t receiving any text messages nor any phone calls so I did a factory reset still didn’t work ,then I did a google search it mentioned to download watch droid and watch droid assistant well that worked but my problem is it won’t stay connected. I even bought a nano sim card but it doesn’t work I use straight talk they said they do not support sims cards but they are working on that in the near future. Any suggestions/help as to why or how to keep my watch droid apps connected. I gave them the permissions so I’m not sure what else to do

1 Like

Goto watchsettings- apps and notification- special app access- unrestricteted data. Enable watchdroid.
Make sure that watchdroid on phone is disabled from battery saver.

2 Likes

The optimizer kills background jobs.
Go to app drawer:
Optimization->CleanTask->Click the text to enter the list of apps
Be sure to locate the Watch Droid in the list and disable it, so it won’t be ‘Optimized’=killed.
Do same for any other app you would like to stay active as background process.

2 Likes

I have a new Kospet Prime 2. I can’t get Watch Droid Phone to connect to my Prime 2. I’ve installed Watch Droid Assistant and have gone through the pairing procedure, so WD Phone sees the Prime 2 it’s just not connecting, even though it tries every 5 seconds. I’ve enabled unrestricted data for Watch Droid on the watch and I’ve excluded Watch Droid on phone from battery saver. Any suggestions? (It did successfully pair a day or two ago, but it kept dropping the connection. Now it won’t pair at all.) As an aside, I do get a successful connection with WiiWear, but I’m not sure what that does for me. I want to get notifications for Gmail and Messages.

EDIT: l tried a few things and managed to get it connected, but then it would disconnect when I turned off the screen and not connect again until I opened the Watch Droid Assistant app. I finally figured out I needed to open the Optimization app > Clean Task > tap Battery Saver > turn off for Watch Droid Assistant, now it appears to be staying connected!

EDIT 2: Just saw that what I “finally figured out” re the Optimization app was already suggested above in this thread and I missed it. Duh.

1 Like

Its usually best with WD to pair you watch and phone normally without qr code . Then go through setup . After a reboot you will sometimes have to open WD once then it will stay paired until the next reboot .

And yes needs to be off in battery saver / not optimized and has unrestricted data access

1 Like

Can’t connect via watch droid says fsiled to connect

Don’t pair with the QR code. Use the Bluetooth pairing Option instead off.

1 Like