Kospet Prime 2 is dead!

my worst fear has come thru…my kospet prime 2 does not charge anymore…put it on charge yesterday after work, took it off after few hours to see it was at 4%…thinking maybe the charger was not lined up properly, i turned it off and charged it overnight…this morning i had 8%…i have 2 cables…tried both…i get the charging animation when connected and when connected to the computer i can get to my files, just no charge…anyone any ideas??

Have you tried cleaning the connectors with alchohol ( small amount )

yess…cleaned the contacts…did not work…i am really bummed…i sold my ticwriss max and max s because i liked the prime 2 best…now i am without a watch…

1 Like

Although you charged it overnight ( not recommended ) it shouldnt have killed it this quick .

So if you have tried all the following -

Cleaned connectors
Factory reset
Flashed firmware ( just a precaution but wont hurt trying )
Tried both cables you have
Tried various usb ports

You will have to return it i’m afraid

Two pins are for charging and two for data transfer . I dont think Kospet will accept a return if you open up the watch to have a look

Have you tried charging with your pc, a wall charger or both ?

1 Like

yes…tried everything possible…i have 3% charge left, so pretty much finished trying…tried both cables, different chargers and pc…nothing charges…the rest works (charge animation, pc connectivity), but no charge…

Sad news i’m afraid . You will have to return it

i think so too…isnt there a moderator who is in contact with the kospet store thru aliexpress? maybe he could ask them what the best returnpolicy is? thanx

There is @pablo11 . He is in contact with Kospet

He will read this post and advise :+1:


Yep, you just need to email them at
Kospetsmart@gmail.com and tell them that you have been here and tried everything…
They will help you.

It is most likely the rear cover contacts


thanx…just sent them an email…cross my fingers…


Please let me know if you have issues or cc me using zappa1.pf@gmail.com which is my email.

no response yet…will keep you up to date…thanx for the help

I have also kospet prime 2 (bought December 2020) and one morning I noticed the it hasn’t loaded the battery overnight. I checked the cable and I think one pin didn’t has the contact, it was always down, maybe the pin was loose, not fastened in the cable. So I ordered new cable from Aliexpress.

The cable came about 2 weeks after and I tried it, but the kospet only flashes the kospet logo, then goes black screen and the same thing repeats all the time. Could it be that the battery went so empty, that it doesn’t recharge any more?

Anyone got these problems? Any solutions?
Best regards, Kari

I had a similar thing which was fixed when i flashed the firmware

Make sure the watch is totally dead before you flash or the bootloop will start again before flashing works


Being a Prime 2, I hope you ordered the correct cable.
The Prime 2 is opposite to almost all other watches.
That’s why I posted the warning at the start of the Prime 2 support thread.
As @Dr_Andy_Vishnu has quoted in his post above.


I hope so, the product specification says: "* Original KOSPET PRIME 2 Smartwatch Charger Line USB Data Cable Charging Cable For KOSPET PRIME 2 Watch Charger Wire Accessories*
and it was from Kospet original store.

Tomorrow I will try the flashing operation, hope that helps … but if the battery is dead, that could be a problem…

Thank’s for helping @Dr_Andy_Vishnu @pablo11 !

No, it’s no problem. Flashing is possible even if the battery is emty. Use “firmware update” instead of “download only”.

1 Like

I did it by the instructions (download only). The firmware was D09_KOSPET_PRIME2_V1.4_20201031.zip. It went ok to the watch. But now it is really dead, it doesn’t charge, flashtool don’t recognize it (I tried the firmware upgrade), all lines are inactive and it doesn’t list watch on the left side.

Is there still some wayto get it up?

br, Kari

Have you tried different USB ports? Make also sure that the contacts are clean.