Kospet Hope screen calibration

I truly apologize to the administrators for sending a second request with the same content, this is the first time I post and the first post got sent unfinished by accident.

So I am a little lost and don’t know what to do. I have a Kospet Hope regular version (3 Gb RAM and 32 Gb Storage), that has been working perfectly for a long time. The case started to wear down to the point where the straps would fall off so I was not able to strap the watch to my wrist anymore.

I found out that the Kospet official store on aliexpress was selling the screen, case and buttons as one piece, so I ordered one.

The screen only has 2 flex cables, and the process of swapping the pieces is very easy, you only have to disassemble the watch and move the motherboard and battery to the new case which also contains new buttons and a new screen, then connect the corresponding cables. What could possibly go wrong, right?

So I swapped the pieces and when I turned on the watch the screen seemed to work fine but the image was off by a centimeter or so, and also the touch sensitivity was inverted (touching the top is like touching the bottom and touching the right side is like touching the left one) as well as off by a few millimeters.

The first thing I did was double check and then try a screen calibration app that I had to sideload and struggled a lot to launch since the touch sensitivity was inverted

I ran the calibrations and no success.

So I contacted the store and asked them about it. They said it was probably an installation error, which I thought was impossible but double checked again.

I also tried taking it apart again and trying the old screen. So with the old screen I had to plug the same 2 cables (I mean their counterparts) and connect them in the exact same way. The screen worked perfectly.

It is worth mentioning that I looked very closely in both cases to check that the pins from the cables were properly aligned when connecting them. Both have some sort of standoffs on the sides that stop you from misaligning them.

So I contacted the store again and asked telling this and asking if they could tell me how they calibrate the screens, but they have not replied. And even I they did, I don’t know if they assemble the watches themselves or receive them assembled from the factory, so I don’t know if they will have the technical knowledge to reply.

I would really appreciate any clues on how to calibrate the screen, as it seems to be working fine. I had set up the watch with a triple tap gesture to enable the zoom feature from the accessibility settings, and when I use it, the zoom portion covers the whole screen, so I know the screen is fine. I also enabled the system to show the cursor when you touch, so I know that all the screen area is responding to touch.

I am guessing that maybe some settings should be changed on the rom itself, but I really don’t know if that would be the way to go.

Any help will be appreciated!

I guess you need another firmware for this screen.

3 Likes

Thank you!
I actually posted this by accident, it was my first post. So I completed the post and sent a request again, I really hope the administrators approve that one, I explain everything I did there.

I fill definitely look into firmware though, thank you very much

1 Like

Friend, did you find any solution to the display problem? I have a Kospet Hope with the same difficulty with the screen all wrong.

Friend: Please don’t send me messages.
I am unavailable due to various reasons and I don’t respond to personal messages - even when I am ok.

@Daniel_C @G1NT0N1C there is no different screen firmware available for this model.
The issue with these screens is a custom touch panel driver which can cause issues if used with a new screen or if the boot image is ever modified - like using Magisk or from any other root process, for example.

@souzafl what is your current firmware version and is this the firmware that was on the watch when you bought it ? Did you buy it secondhand (used) ?
It is only ever a problem if you mess about with firmware as I said above.

Given that this watch has not been produced by Kospet since 2018 - I very much doubt that any other screen will work with it properly.
The amoled screen was always an issue with this model and the touch zone was crazy sensitive.

@pablo11 friend, I won the watch. Yes, it is used, and when turned on, it already presented this problem. I tested other firmwares to find the fix. I managed to improve, but I didn’t solve it. I was hoping that the lite version firmware would be the solution, and this version is the only one that I can’t find in my searches. no root or magisk installation was performed on any of the firmwares I tested. the bootloader remains locked.
thanks for the feedback.

Bootloader is never needed to be unlocked on this - so it’s still possible that you have a custom boot image.
Is it branded Kospet or Madgaze? Does it have a camera or not?

This is the only 1+16gb version I have I think.
If it’s 3+32gb version - there are many others to try.

1 Like

@pablo11 Friend, thank you very much for sending the firmware. I’ll test it tonight, as soon as I get home. Yes, it is from the KOSPET brand. It has a camera! I actually tested several images, but I couldn’t find a solution to the problem. Display is always displaced. Or all the way to the top left (with firmware from other models). Or moved to the bottom right and with the image inverted with the kospet hope firmware version 3+32gb. I’ll test it and get back to you if there’s a solution. thank you again.