I wanted to reset it to factory settings

Good evening guys.
I have a kospet prime 3/32.
I had done root and I passed and twrp.
It worked perfectly.
I decided to sell it and I wanted to reset it to factory settings.
I did it through the clock settings and when restart opened, but went to twrp and says there is no software inside.
I press off and when I connect it to the charger and computer to pass a rom opens on its own and goes back to twrp. I don’t know what else to do.
Thank you very much

did you press download in sp flash tools before you connected the watch?

Yes, I did.
But it doesn’t stay closed.
Opens automatically and goes back to twrp

Closed should not be when I pass a rom with sp flash??

Can i install rom if the watch is in twrp?
The watch cant stay off, since i connect it with the pc it turns on.
Is there another procedure?
Should the watch definitely been off to install the rom or can i install it when it is in twrp?

I believe you can install the rom from twrp. Just transfer the system.img to the watch and in twrp choose install from image.

But how am I going to transfer the rom if the computer can’t find the clock? ??
He’s telling me all about an unknown device.
Also I will not put the rom as zip??
Where is system.img

If I do unzip will be inside system.img??

Thanks very much

when you unzip it there should be two folders, one called “database” and one called “image”, system.img is inside the one called “image”. you can turn on mtp from twrp or you can use an adb command like this “adb push C:\Users\Alexa\Downloads\KOSPET_PRIME_v2.3_B_20200706\image\system.img /sdcard/”

What function should I put it in??
From the twrp what should I choose???

system, power off, recovery , bootloader???

If I put power off mode , opens in twrp

The clock will be turned off and once I connect it to the charger it will open entering a twrp or it will be in twrp

right now, I can’t get mtp to work in twrp myself either. It says it’s enabled automatically in my case, but the way to turn it on manually is to first press the arrow to the right, then “Mount” and then “Enable MTP”
but if you can’t get mtp to work you can use the adb command as I said. If you don’t have adb on your computer already you can download it from here: https://developer.android.com/studio/releases/platform-tools

The watch only in twrp recovery mode goes.
It doesn’t close permanently.
When I connect it to the charger it automatically opens in twrp
Wants other drivers to work the adb or the ones installed for sp flash tools???
It must be power off for the adb to work or in twrp or in bootloader???


let it stay in twrp for adb to work. all you need for adb is the platform tools I linked to. you have to unzip it and then open a Command Prompt or Powershell window in the “platform-tools” folder, then you can start with the command “adb start-server”, then “adb devices” to see if you’re connected (it should tell you the serial number of the watch and that it is in recovery mode), then you can use the adb push command above, just make sure to change to the right file path

Thank you very much.
I’ll try it but the computer doesn’t recognize the clock and says all unknown device.
I’m getting on my nerves
Thanks :grinning::grinning:

that doesn’t matter, it should work anyways

He doesn’t see the watch as a device. :sob::sob::sob:

List of devices attached but does not write some numbers.
With sp flash I can not install the rom??
It is absolutely necessary that the watch be power off or done in twrp mode??..


If you have accidentally disconnected the watch during the flashing process, it is now stuck on the preloader.
Try to push both buttons for 20sec. to force a reboot.

It restarts normally but does not open the clock and goes to twrp. He tells me he doesn’t have any software installed in it

Hi Gthom, I have had this problem, I solved flashing again the firmware with Sp and installed default recovery and boot.
I hope it’s useful for you.

1 Like

Thank you very much.
That’s what I’m trying to do, but the computer can’t find it. He’s telling me all about an unknown device.
That charger’s really stupid after all.
Thank you again very much


when the clock is in the charger in twrp, try to click download in SP and then immediately restart the clock, witout move it form the charger. for me when the clock restart, the firmware flashing start correctly.

Can you tell me which drivers you’re using?
I use them on windows 7 v1.1032.0. has in it an InstallDriver file and usb2ser_Win7