Any body know how to root this device?
I want try to some apps but need root so please help me if you know. Thanks


Why do you need root to try apps ?

I need try screen resize “the apps need root permissions”

I dont understand . Do you want to simply turn the screen to square mode so you can use apps ?

1 Like

For example changing dpi settings should require root permission.

No i need to change dpi settings

Do you know how to root KOSPET OPTIMUS PRO

Have you read this ?

1 Like

You’d have to get a dump of the firmware you want, you can get v1.6 from the forums or v2.5 from OTA with wifi. Not really sure how you’d be able to extract the 2.5 prior to patching.

[Note] A quick search on the kospet forums shows the v2.5 may have problems. [/Note]

I’ve never done an OTA so i don’t know if it saves it to the watch first, possibly as a zip and then lets you flash it at a later time.

IF, and this is a big IF IT DOES save it as a zip first, then you can copy the zip to your PC. If you get this far, i can walk you through the rest. But i have no clue how the Kospet’s do their OTA updates.

I still don’t even have the latest FW for the kospet hope, since i got mine from the website.

If you use the V1.6, then copy the boot.img from the zip to an android device, the watch can do it too. run an app called Magisk Manager to patch the boot.img. Copy the patched_boot.img back to the firmware folder rename it to boot.img replacing the old one, run the checksum_gen.exe, or delete the checksum.ini.
Then continue to update your Kospet the same way you normally would following the v1.6 instructions on the Kospet forums. If you’ve already installed v1.6, then you only need to flash the boot.img, and not everything else.


Magisk Manager

PS you should also TWRP your recovery.img but i don’t know how to do that. Someone else did it for the Kospet Hope and i used their’s.


@Rifky_Samudera, have you tried to turn on “third party apps adapter” in the settings? That setting will set the dpi a lot higher. It doesn’t let you specify the dpi yourself, but it might be worth a try.

I don’t know it same or not because this optimus pro is dual sistem

My firmware is 2.5 from update ota
Oke I’ll try to use this magisk

Oh ya? Oke I’ll try this first

1 Like

i m having thor 5 dual … please help me to root it … as i had tried the twrp of all(mtk6739) devices like thor 4 dual , kospet hope (as mentioaned above i thought optimus pro and thor5 are all identical watches) but no succcess and also i had already patched my boot image with latest magisk but after flashing and booting into recovery it just shows the zeblaze logo then keep screen black for 5 sec then boot normally!!!

if you only want root, then there’s no point wasting time on getting twrp to work. If you have flashed the patched boot image then it should be rooted already


you had posted a comment before to your last comment … please tell me process as you had told that patch the boot image not by any other phone but with the smartwatch itself(where i m not able to select boot file as it only shows the downloaded files no option for file manager)… and do after flashing the patched boot images and then installing magisk manager gives me root privilages??? if so then i had already flashed the patched boot image(with some other android device not by smartwatch)and then installed magisk manager but magisk manager is not showing rooted

Hi I was the one who told to patch from watch itself,and to do that,first you will have to upload boot.img on some uploading site and download it on your watch,for some reason magisk manager can access only download manger so if you download boot.img and try to patch it,it will be showed in list.
The problem with patching from phone is that,if your phone is 64-bit the boot.img is patched with 64-bit modifications,but our watch is 32-bit so your watch will not get rooted.So procedure:-
1)upload boot.img somewhere
2)download it on watch using browser
3)patch it with magisk manager from watch
4) flash that boot.img
It should get rooted now


thanks a lot bro i had root my smartwatch succesfully … thumpsup for you … i had rooted for two things
1 remove some bloatware
2 changing the always on theme and brightness
3 modification in long stanby mode(like changing the brightness of long standby)
4 want to flash kospet optimus rom in my thor 5 as i had gone through and found only preloader has diferent stack size otherwise all files are identical …

if you can help me in any of above problem then it would be great for me…
thanks a lot

Hi dear Shivam,
I have thor 5 dual and I also want to flash with Kospet Optimus pro ROM.
Will you maybe succesfuly flash kospet rom on thor 5 and how please.
Thank you very much men.

Hola, alguien podría compartir el “boot.img” del Optimus pro parcheado? es que estoy teniendo problemas con Magisk y necesito rootear.
Muchas gracias