hi i have a no1 d5 i cant connect to internet using sim card

i have a no1 d5
i cant connect to internet using sim card
in APN there is no way to edit or add
only empty screen
(attached pic )
can you help me ?


What did you do?

nothing it came like this

I can only suggest looking in the FAQ and Guides section of this site… hopefully others will try to help too…

thanks andrew

Did you insert the sim card right ? Or check with another one.

yes i did
i can make and receive calls
tried with another sim also and have the same results

so you have no APN Data, but you can make/receive calls and Internet is not possible. Is this right ? With which app do you get this empty APNs Display from your posted foto

that is correct ,it works on 2g and 3g (now set on automatic )

regarding the empty APN display its from the watch itself ,no outside app
settings - connect - mobile networks - Access
point names

i even tried rooting the watch and pulling the apns conf file and it looks ok (not corrupt or bad to my telling )
i edited the file to hold my carriers settings and pushed it back and still i got the same results
also tried different roms and full reset
and nothing changed

If you have tried Loki’s custom rom and still no luck you may have lost your IMEI number. Check in “about phone” under settings. Hopefully you backed up your NVRAM before all this happened - by the way - have you ever had a data connection from your sim since you bought the watch?

PS: The APN list will also appear blank if your APN is not in the configuration file.

hi pablo
first thanks for your replay
the IMEI no is there and not lost

the APN list was empty from the start
i received the watch like this
so no data connection from day one

but you gave me an idea , ill try to edit the apns conf file again i might have missed something .

@Momi_Az here are the APNs https://drive.google.com/file/d/0B3xyOuab2f-OWVVlZ1Frby1ycjQ/view?usp=sharing
Don’t forget to set correct permissions after copying to system/etc

When I go to settings, connect mobile networks, access point names I see my network partner ( telecom ) , but I am also able to add a new APN. The buttom at the top of the display is an add buttom ( not only APNs like in your foto )

hi pablo
i couldn’t push back the apn file you sent me but i did manage to edit the existing one with QuickEdit app from play store (great app by the way)
even after i did i still cant get any results ):
if you have any more suggestions ill appreciate it a lot
thank you and every one ales for taking the time trying to help

So - I’m guessing you have root access ?
The way to do this is to download a root file explorer and make sure the etc directory is read/write. Then rename the existing apn-conf.xml file to something like OLD---- and then copy the file I gave you to your SD card and then copy it into correct it’s place in the etc directory. Then you need to long press on the new file in root explorer and set permissions as rw-r-r-
Then reboot.
As an after thought - have you made sure that cellular data is enabled in settings? Mine came with it off by default :slight_smile:

i had the same problem with the k9 in my country the watch was’nt supported and the D5 is.

@Pablo_Eleven_Pablo11 the mobile network state is disconnected b
i guess its the result by not being connected
if i check status
i can see the provider name - golan t
i have signal strength(changes)
mobile network type - hspa
service state - in service
roaming - roaming
mobile network state - disconnected
my phone no - unknown
ip address- unavailable

@Pablo_Eleven_Pablo11 ok i did it all again and i succeeded changing the apn flowing your instructions but still i get no list on apn screen ()like in pic)
i checked again and data connection is on
i saw in xda that i need to ad an entry on db
but when i open the file i cant understand how and what to do
do you know about this ?

hi every one
i finally got it to work
now have 2g 3g and can access
the web on sim
thank you so much for your help every one
pablo you are great
cant thank you enughe

hey, what did you do?