Help with bangood warranty

Hi everyone, indeed all thanks for having welcomed me into the group, I am Marco, an Italian boy, I apologize both if I posted incorrectly and for the errors of the language, I write with the translator, I am the owner of a Lemfo Lem X, also to me from display problems, the grid and appearance and the touch no longer works well, in the right part even above the lower right in some cases is non-existent, I wanted to ask given it purchased on Bangood and is still under warranty until January, if you can help me for the replacement thanks for the kindness, Marco

Hi Marco . Have you performed a full factory reset and upgraded the firmware ? If not try this first . If this doesnt work you have a hardware issue which you can take up with Banggood . I cannot assist you with this . I would suggest you keep on at them if you dont get anywhere with this . Thankyou

1 Like

hello Tim pleasure and thanks for having responded, yes I did reste, hard reset, brought 3/4 times to the factory settings, moreover it does not give me more option for usb to connect it to the computer, I can only recharge it, I also took a new cable reloading and data but nothing, Firmware updates no longer gives me …

Clean the contacts with alcohol. This might help to flash the Firmware.

I don’t think it’s a hardware problem, I think as I’ve read in this forum, it’s the pixells that die, the famous grid :frowning: also appeared to me

Yes, I’m afraid you’re right. But I learned that it is better to exclude everything else first.

1 Like

Hi G1Nt0N1C I regularly clean the contacts but it just gives me as a non-data recharge does not make me open in USB computer mode

Is it connected with your computer? I’m asking because I can’t see any cable on the picture?

Tim This! Is my firmware

now connected, but unfortunately nothing changes, the computer however I have already tried on other computers gives me “USB device not recognized” :no_mouth:

Strange… win7 should work without any problems. Did it ever worked before?

yes it all worked perfectly in fact I also have a folder on the computer of Lemfo lem x

hi Louis I have already tried I bought another original cable, the same thing

1 Like

Yes. I saw that after I read your post more closely. I personally think you should just get a new watch, being Christmas and all!

It usually takes several times to have the correct connection on the watch, maybe a dozen or more tries… even if it seems the magnets are correctly doing their job.


I ask if they can send a new x visa and warranty, but I don’t think it will be easy,

… Hi Erich, first he gave me the option on the clock appeared the USB icon turned on and gave me the various options for charging, for data ect ect I don’t remember well, now both with the old cable and the new one I do not give this option anymore the USB icon is off, when the attack on the computer gives me “USB devices not recognized, but it charges

Update the USB drivers on your computer.

As I said, it can take tenth of time sitting the watch on the cradle,before the usb connection is correctly made and this usb menu is proposed…

hello guys, I have both updated the drives and tried on other computers, it only goes in charge mode, on Windows 7 it tells me not recognized USB device, on Windows 8 the same, on 10 it doesn’t even read me as an unrecognized device, it doesn’t give me nothing, you just take charge …