Google assistente kospet prime

Google assistante was working fine until today. Now when I open it, I have the following message

There are no available updates on Google play. Anyone with the same problem?

Thanks in advance

Are you using a prime SE ? If so it will only work on occasion due to memory restrictions

1 Like

Hello thanks for your reply. No, im using the normal version of kospet prime. I’ve tried restarting it, reinstalled google assistente but without success…
It was working fine yesterday, and didn’t installed or updated anything.

Have you disabled the Google app? If not is it on the latest version ?

Maybe, by reinitializing your watch. It solve many problems.

No I haven’t Google app it’s working fine. I was avoiding a factory reset… But in the end, it should solve the the problem.

It’s not just you, the same happened to me. Looks like Google broke Assistant for our watches :frowning: Google voice search is still working though.

I just checked the requirements for Google Assistant. It now requires a device with 720p or higher resolution. Looks like we’ll have to wait for another generation of watches to use it again :frowning:

in that case, make it two or three generations

1 Like

I would not wait for it. Google doesn’t seem to want it to work on Fullandroidwatches. Just like Bluetooth calling…

1 Like

That’s bad news :frowning: one of the main reasons I bought this watch, was to use Google assistant

1 Like

This is disheartening!

Let’s have a look at this. Maybe there is a workaround…:wink:


I have not updated my Google app or assistant for a while, and GA works fine
So an older version will work (I’m on version
Update- works for me on the latest version too ?
Maybe try doing a factory reset, might work after that

1 Like

I just checked it on my Kospet Prime, it’s still working, even in the newest Version. Try to delete all app data, uninstall aplication. Then reinstall.
If this is not working, I would try a factory reset.


It’s still not working on the three of my watches on which it’s installed (Prime, Lem T, Lem X). Could you be confusing it with the Google app, which is still working? Google Assistant is a separate app that supplants or augments the Google app.

Very strange. What version of Assistant do you have? Mine is 0.1.187945513

It’s V0.1.187945513. Try a factory reset. Assistant wasn’t installed on this device before.