Call Recording problems

This is for enquiries about call recording.
Moved from the Watch Droid support thread

Tried moded Google phone app
Tried to define Google phone app in watch droid settings
Same-same. No caller ID, no number. Nothing.
Only “Call” is written on my watch :frowning:

Phone: S21 Ultra, Android 11.
Watch: Lemfo LEM10 (3Gb +32Gb version)

If you have Google contacts synced and grant the correct permissions it will work.
So remember to give Watch Droid access to the contacts on your watch in apps, permissions.
It also depends on which watch you are using - Android 10 or 9 or what?

Thanks to both of you for your fast reply.
Problem is - I need call recording and I have it only in the stock phone app.
Had to abandon so loved “True phone”, that was used for years.
With external recording apps, for “line” call recording root is required and I’m not going to root this device (bunch of reasons).

Phone: S21 Ultra, Android 11.
Watch: Lemfo LEM10 (3Gb +32Gb version)

Any suggestions?

Cube ACR works on A10 without root - supposed to be ok with 11 too - but I haven’t tested it.
I use it all the time.
Sorry for off-topic remarks @lumaticsoft

1 Like

Thanks for your suggestion. Tried - recording in slow motion or not recording (with other options).
If you have ideas, will be glad to hear them (in PM in order to avoid further offtop)

I really think that you (I guess :slight_smile: ) made a wonderful piece of software. Thank you for all the efforts to improve this app.
I understand, that I just need to patintly wait until you discover/develop required feature.

Falling back to v.9.1 that works correctly.

Cube ACR works fine for call recording.
I use it all the time.
Not as part of Watch Droid but for the watch phone calls in general.

It requires permission from the Accessibility settings.

Oh well, sorry it didn’t work for you.

So, which watch are you using?

Lem10. Added to initial post

1 Like

So is this just about call recording on Android 7.1.1?
Watch Droid has nothing to do with this.
The developer can’t just keep making the app compatible with old versions of Android. He is focusing on the newer versions of the OS because it has changed a lot since A7.1.1.
I will create a new topic for this discussion because it doesn’t belong here.