Brightness won't change

I got my Genesis on Monday. I’ve not been able to change the brightness. Neither method on the attached images change the brightness.

What is causing this?

I had another problem where the phone would not turn on when moving my arm up. I believe it is called Hand bright screen. As I recall I fixed it by messing with AMOLED and/or CryptoWake AOD.

What does the AMOLED app do? I was able to locate CryptoWake in the play store and read about it but determining which app AMOLED is is hard; so many with the same name

Could another app be giving me grief with the brightness. BTW, I did the initial flash/reset when I got the phone. Thanks

Have you tried a factory reset?

1 Like

The Amoled app is terrible for battery . Dont use it . As @G1NT0N1C said a full factory reset should fix this . Please note the brightness adjustment in the genesis isnt huge from middle to high . Thanks .

Do you use Vysor?
I had the same problem. The fault was Vysor apk. After uninstalling and resetting the smartwach the brightness worked normally.

1 Like

Yes, I have have done the factory reset when I first got the watch but not again. Doing it again will be last resort.

I just froze the AMOLED app.

Yes, I tried Vysor but the brightness problem was happening before that. I used Vysor on my LinuxMint machine and the picture was really blurry. I just uninstalled it.

What about this CryptoWake AOD? Has anyone had problems with it?

You will find probably only a reset and clean start will fix this

Just wanted to pass this along in case it may help someone else with a similar issue. Not saying you will experience the same thing. I had to do a Factory Reset(FR) on my Genesis because the Power Save feature stopped working. I was in the process of re-installing all my apps and data from my computer. I re-installed my apps from my apps folder and this time added Vysor to my apps for the first time on this watch. Moving ahead, after most apps were up and running I noticed my Back Button had stopped working and also did not change the brightness of the watch. But the brightness Icon did change, just not the actual screen. After several FR’s and eventually installing apps one at a time I discovered my Smart Touch Pro(STP) app and Vysor were the source of the problem. Install and set up one or the other and the watch was normal. Install and set up both and the problem resurfaced every time… Btw Vysor and STP both worked normal, just the Back Button was effected. Uninstalling one or the other or both apps did not help, only a FR. So I had to make a decision and did a final FR and kept the STP app. While Vysor is very handy I rarely use it while I use STP constantly during the day and the Back Button works normal,normal.


Just uninstalling Vysor does not help, you must make a factory rest after uninstall and then everything returns to normal with your brightness button.

1 Like

finally did the factory reset and the brightness button works! Thanks to everyone assisting.


Great news . :+1:

I have just had the same thing happen to me, I installed Vysor as it was given a recommendation elsewhere on this blog but found my brightness and colour level suddenly drop off!! And yes, moving the brightness slider up and down makes no difference. I have looked into all the power saving settings etc. can’t find any way to get it back to normal. I also had my music player app shutting down after a few minutes and saying a power management issue on my Android device may be the culprit…fast forward to reading this subject chain and will obviously have to do a factory reset sigh hope it works.

So…interestingly when I did a factory reset I once again had the issue where my watch seemingly died and would not turn on. So there must be some kind of bug with the factory reset function. Fortunately I have been through that issue before so did the press both buttons trick… took 20 seconds to come back to life. Annoyingly I now have to set everything up again but lesson learned. DON’T use Vysor.

1 Like
  1. Run VYSOR
  2. Open SETTING
  4. Dim Display While Connected OFF

I never had the ‘dim display while connected’ box checked. And during my attempts to fix the low brightness issue I tried checking and unchecking that box to no avail. Anyway, I did a factory reset and I’m not going to bother with Vysor.


As I indicated in my other post I’m not sure its just Vysor causing the issue. It may be certain other apps working in conjunction with Vysor. In my case Vysor by itself worked fine. As soon as I installed Smart Touch Pro(STP) I started having problems with brightness settings. Or if STP was installed as soon as I installed Vysor the problem returned. STP has nothing to do with the Brightness settings. I currently still use STP and have no problems without Vysor installed. But when those two apps were installed the problem resurfaces each time. I confirmed this by numerous Factory Resets and re-installs.
I also have started using Display Brightness(DB) app again because the back button(BB) adjustment was just not sufficient for my needs. DB overrides any other brightness adjustments on the watch so I may reset the BB hold option, to another function using the Button Mapper App, from Mr. Ticks camera video. I remapped the BB double tap to turn on Insta Camera.

1 Like

Hello everyone! I apologize if this had been answered in other threads, but I am having the same issue with my brightness levels listed above. Is there a way to backup all my apps and settings before doing a factory reset? I believe I had seen someone answer this before but could not find it when doing a search. Thank you!

I found it! It was @Jonathan_Bickel that answered the question:

14 Jun

I learn this technique from Mr. Ticks and it sure simplifies having to re-install apps when you have to do a or multiple factory resets. I download the apps i’m going to use to my phone. Use App Backup and Restore App make a backup. Connect my phone to the computer and download the apps from my phone. Put them in a file on my computer. I now have a copy on my computer which I can also use on all my watches. Connect the watch create a folder in File folder called Apps. Now you can install the apps from this file. After a factory reset load all your folders back onto the watch and re-install apps from folder. If you load App Backup and restore on your watch, when you update an app, you can keep a backup of that update on your watch to use for future installs. You can also store apps in the folder, from you phone that you may not be using but may want to try and can install them at any time from the folder.