Brand new Prime 2 not charging

It appears my Prime 2 is not charging…

I’ve tried multiple usb adapters (all work fine with my other devices)

The screenshot show the charge dropping from 33% to 31% whilst on a charger.

Any advice?

I would first begin by cleaning the contacts on the watch with alcohol. While they may not look dirty, even a minor film on the contacts can keep the cable from making a positive connection.

I’ve also tried charging the device whilst it is off. But to no avail - charge is still falling…

Ok I’ve cleaned the contacts - leaving it on charge for 30 min

Still dropping :frowning:

Note that the watch always indicates that it is charging (except it isn’t)

Do you have the opportunity to check the charging cable with a measuring device?

No - I’d have to take it to a repair shop…

Do you leave the screen on when charging ? For example, the S08 is nearly impossible to charge because the screen keeps turning on and it uses more battery than it can charge…

I’ve tried:

(1) Watch on, screen on
(2) Watch on, screen off
(3) Watch off

Also tried charging using windows 10 laptop (USB 3 port)

Basically charge is only heading downwards.

Do you have an inline volt/amp meter to measure the voltage and current being fed to the watch. It would probably tell you what is actually happening.

I don’t have a multimeter. Will consider taking it somewhere tomorrow

Maybe a FW reset could solve this.

I’ll give firmware reset a go whilst I still have charge (24%)

But I’ve never done it before, is there a link with some info?

Current firmware…

Just go in settings/ System and reset options

1 Like

Sigh… wont do a reset if battery is less than 25%


Now down to 18%…

Please power off your watch now. Flashing the firmware will still work, but we need some power left. But- not sure if flashing will solve your problem. Just a last try…
I think it’s a hardware problem.

Watch has been powered off for last 2 hours - although charge was down to 12%.

How do I flash the firmware?

Edit: If it is hardware, will flashing the firmware help?

If it’s an Hardware problem, flashing won’t help. But otherwise it will help.

Here is a flashing tutorial:
-LEM12 Pro A10 Official Support

I’ll send you the link to the right firmware later.


I don’t have the firmware at the moment. Please be patient, you’ll get a link soon.


I just hope I have enough charge…

Can an incomplete firmware flash brick the watch?

And If bricked, will Banggood still replace the watch under warranty?

FYI: I have reported the problem to Banggood. Apparently I should get a response within 24 hours.