X5 air fw 170825 request

Touchscreen not working after flash every firmware

postimg.cc/dDHmTngD

Can you give me the details of the firmware which was on the watch when you got it please?
Most of the links are disabled for this very reason.
Different ram and screens used.
Cheers

The device was in freeze mode and i had to repair firmware without knowing about the previous version. I tested several firmwares, but none of them have the ability to modify the touch, even the custom firmwares, you can see uploaded hardware details on the mainboard image
postimg.cc/dDHmTngD

Need to know firmware version to know screen and TP type

hello again,

W618 V1.0
w618-11-2018010501
X5S0 64+8G
This is all that was written on the board.

Yes, as I said before - the information we need is in the firmware version detail.
I’m guessing that this means that you didn’t take note of the original firmware version before you started flashing firmware?
I am curious to understand why you started flashing firmware?

Or did you purchase it in this condition?

Unfortunately, either way, this is going to be extremely difficult because the solution provider (Finow) did not keep their old firmware when they stopped.
They no longer make Android watches and maybe don’t even exist anymore.

So the only firmware is when I have.
Can you at least list which versions you have tried already?

This could help me identify the touch panel version.
Are you certain that this is an X5 Air model?
What makes you think it is definitely the “Air” version…?

Hello and thank you for your reply,
As I said before, I could not access the device details in any way.
Because the device suddenly turned off and could not be turned on by any method, I had to perform the firmware download method.

Device is X5PLUS

Hardware (lable on the board):
W618 V1.0
w618-11-2018010501
X5S0 64+8G

Failed Versions (that are not successful):
Stock Firmwares:
w618_wgl.x5plus_ddr3.common.80.emmc.w.s.170327-183955
w618_wgl.x5air_16g128g.common.80.emmc.w.s.170718-203130
w618_wgl.x5air_16g128g.common.80.emmc.w.s.170919-111124
w618_X5Plus-v.s.180718-1531902040
Finow_X5_Plus_MT6580_161125

Custom Firmwares:
X5Air_mod_by_Vell_m10.5_full_SPFT-283c161d
x5plus_mod_by_Vell_m08_full_SPFT-005e07d7

Can you help me please ?

I’m not sure how I can help you.
We don’t know what the correct firmware is.
You have flashed custom firmware that will have changed the original partition layout (almost certainly).
Do you actually know for sure which model you have?
Is it an X5 series 1?
X5 Pro?
X5 Air…?

It’s difficult to help with such little information.

1 Like

This is the image I uploaded:
postimg.cc/dDHmTngD

Yes, exactly Device is X5PLUS, and this is written on the label inside the back frame of the board, which I have uploaded. Did you not see the picture?

W618 V1.0
w618-11-2018010501
X5S0 64+8G

It looks like you have the same issue as here : Lemfo Lem5 W618 v1.0

2 Likes

hi eric thanks for attention, but there is no any solutions. :expressionless:

Ok thanks.
I’ll get the various X5 Plus versions I have (if I have them) and I will give you a link by message, to download them.

I hope we can help with this situation.
By the way, you will probably need to fix your IMEI and the wifi & BT Mac addresses after flashing.
It’s very possible that the custom firmware versions you tried have wiped the NVDATA partition. We’ll just have to see what happens.

You will need to use the firmware upgrade option in the flash tool. If you don’t, it’s very possible that you may have problems after flashing.

I’ll let you know when I have got the files ready.
Cheers

2 Likes

Yes, I have done exactly what you said
thanks, good luck

1 Like

I have linked you up with the X5 Plus FW I could get.
By the way, you should update your Gmail account as it is no longer correct.
Good luck with your watch :+1:

Links sent.
Please fix your Gmail address here in the forum :+1:

Yes thank you. I will announce the result here :pray:

1 Like