X3 FIRMWARE - Updated : Hi all,

X3 FIRMWARE - Updated :

Hi all,

Just wanted to let you all know that we received firmware for the X1 and X3 dated 20160530 yesterday. Unfortunately the X1 version has issues. Watches find it very difficult to switch between WiFi and cellular automatically on this new update. I have notified the supplier so that it can be investigated further.


@Lokifish_Marz and @Ciro_Danise I’m posting a link to the X3 update as we discussed yesterday. I already had it in my G Drive so may as well.
There is no official change log for this firmware either. It has a few extra faces but nothing much else. Also because I am uploading it here does NOT mean we are officially supporting it !!. Some tests still show automatic connectivity switching to be an issue. I would say that this is for advanced users only and use at your own risk!
For everyone’s information - I have tested this edition on my D5, X1 and found it to be reasonably stable. I don’t think it’s any better than the last update (so it still has the previous bugs and maybe some new ones) but it’s not going to do any harm to try it. And please report back on your findings. This is the only way we can get feedback for future improvements.
If you don’t want to lose your current apps you should make a backup of USERDATA in SP-Tools before you flash and restore it after flashing and booting the new firmware. I know there are other ways but if you know about them I don’t need to write about them.
I will say this - if you update do not flash the pre-loader. Also only select download mode in SP Tools - don’t want any more IMEI numbers getting wiped !!
As always - backup your current firmware before you do this and also use MTK tool to back up your IMEI - NVram.
If you are unsure about any of this DON’T DO IT until you are !!

Good luck.



Is this a new problem in this firmware or carried over from previous versions?

It seems worse on the new version. Testing continues and I’ll give more feedback soon.

Where we can download this for trying? Or it is super-secret stuff only for Masonic Lodge and Chosen Ones? :slight_smile:

Yes, please.

Hi. what did you mean exactly with switching connectivity problem? It lose 3g signal? or what? The original firmware that is in the X3 have that problem too? Thx

It’s a problem with switching between WiFi and Cellular data. For example, if you walk out of the WiFi coverage area while connected to WiFi, it doesn’t automatically switch to cellular for quite some time.
The X3 version I posted here is not too bad but the X1 version was not good at all.

When that happen it lose data connectivity so. But if some calls you or you want to call someone with internal sim card, is it ok? Work it fine? Thx

Making calls can be affected as well.

Ok, thx. Can you give me a link to the original firmware that do not have this problem? I mean the stock one (for K9)

Loki posted it in the stock firmware post in the rom and firmware section. K9 stock is dated January this year.

I still can’t find it. Can you please give me a link? Thx

Hi, Iam new to Smartwatches and I have a X3 now. So i wanted to update the firmware, but Smartphone flash tool is doing absolutely nothing! I was waiting for about 1 hour but 0 b/s, 0 bytes, 0:00 hours…

What iam doing wrong?


My guess is that the Vcom drivers need to be installed correctly and you need to have the watch turned off to do this update.
Have a look at this https://www.youtube.com/watch?v=7lSZMQ6zdN0

thx, can you post a download link of the most stable version, since i heard the latest one is pretty buggy

It doesen`t work… deactivated driver signature on Win 10, installed driver, but its the same result, and watch was turned off of course. if i have a driver installer, do i have to install the driver manually? no or?

Have a look in the guide section - there is an SP Tools set up and flash guide in there.

So now i ithink ive messed it up ^^

Installed the drivers, and tried to flash it there nothing happend again, but now my watch wont turn on again… its just a black screen is there any button combination to set it back ?

worked it out somehow my watch was startin up again, ^^

@Stefan_Han glad to hear you fixed it.
SP Tool flashing is one of those things you really need to read up about before you try it. Also the first rule about this kind of thing is ALWAYS BACK UP FIRST !!! :slight_smile: