Whatsapp notification not showing when screen is off

Hi guys,

Genisis/WhatsApp related issue here.

I’m not getting any notifications on my watch unless the screen is on and I open the app itself. The app is set to unrestricted data usage, not optimised and background cleaner is also off. Anyone else experiencing this? This problem is with both mobile data or wifi.

WhatsApp is my main mode of communication, so this is frustrating.

Appreciate any help.

You need to keep the app open . Have you done this ? Thanks

Sorry, could you elaborate? I assumed disabling background cleaner would stop the apps from shurtimg down.


Try not closing down the app completely . And as you have done turn off in data saver and background cleaner .

I’ve got a similar problem with my Genesis using it as stand-alone. I installed the app Tablet Messenger for using WhatsApp, but I can’t get any notifications from it on the smartwatch, even when the screen is on.
I let it running on the background, and I’ve turned off data saver and background cleaner, but still no notifications. I also let the WiFi always on just in case.
Any ideas on how to fix it?

Appreciate any help.

1 Like

So if you are using as a " standalone " with sim , wifi , data on etc and also have " whats app " installed why are you using messenger ?

Use whatsapp app only with data , background off , leave app open and it should work fine .

I’m not using a sim, just WiFi. And I do not want to keep changing the WhatsApp from my phone to my watch every time, that’s why I’m using tablet messenger.
And still I can’t get notifications from tablet messenger. At first I could manage to get sounds every time I got a message, but no notifications. Now I can’t get either.

1 Like

Go to “Uninstall Applications” and look for Tablet messager.
Do not uninstall, but go to “data” and delete it. Then open Tablet messager. The initial setup is now displayed again.
A menu is displayed during initial setup. You have to scroll down this menu. One of the points is called “Receive messages in the background”. This point must be activated.
In addition, notifications must be allowed in the watch settings and tablet messager must be deactivated under settings- more- backround cleaner- Battery saver.
In addition, the cell phone and the watch also require Internet access. If all these settings have been made AND the devices are connected by scanning the QR code, the reception and writing of whatsapp messages works reliably and without problems.

EDIT you are right, it seems that it’s not working any longer. It was working, even if the screen was off. But I just tryed and I wasn’t able to make it work again.
I will have a look at this.

I presumed you were using your watch as i do with a sim . I have two sims and two different numbers ( one in watch and one in phone ) . I have always used whatsapp as nature intended and never had issues . I have never had the need to use tablet messenger

1 Like

I tested this today, rather than using back button to get out of the app, I go straight to “home”. The app still closes after a certain time, so the only way I can check for a new messages is to open whatsapp again.


Strange . The app when not fully closed should work in the background with the above settings turned off ?

For clarifaction i have just tested whatsapp . Sim in with own number , data , wifi on .

Background and data saver off .

No issues at all . Sends and recieves even when screen goes to sleep .

App left open ( also worked when closed down )

Tablet messenger is something i do not use so we will see what @G1NT0N1C says

I dont have a sim in my watch but i am using watch droid and it works great

1 Like

Thanks mate.

I uave done all that. I have even factory reset the watch and set everything up again.

Kept the app open and then screen off. Three hours later, sent a test message and the result was same. I only received the alert when I turned on the screen and opened WhatsApp.

Now i did test this on a kospet prime as my genesis is at home . However there should not be any difference ? I will check

I have tried everything I could of and the result, frustratingly, remains unimpressive. I guess the app gets shut down no matter the settings.

I have tried “whatstablet” (that’s what this app was named before) and some older versions of tablet messager, but all of them are not connecting any longer. I’ve readed in the playstore comments, there are other people reporting about this problem, so it’s not a problem of our watches.
I have a contact adress of the Developer team because I contacted them before. I will contact them and ask for a solution.

A workarround would be to use a browser and connect with whatsapp web. Give permission for notifications to the browser and disable it in battery saver. It will consume more data, but it should work. (Not tested yet)

1 Like

I think that notifications with the screen turned off do not come, because the means of communication are disabled

I discovered after intense discussions with Dr. Google that it was a network issue not Whatsapp as I assumed (I use 3 UK).

After downloading Push Notification Fixer and setting the data and WiFi heartbeat to 5 mins, my WhatsApp notifications now works perfectly. The app does not put too much strain on the battery.

Possible solution if anyone else comes across this issue.

I run WhatsApp without any issues as it runs on my mobile. You need to turn everything off on battery saver and battery optimizer and it should be fine after that.

1 Like