Updated: Android smartwatch app to auto update weather on raise function

battery saver is deactivated, the screen is already set to 15 seconds and cannot be deactivated by turning the wrist turns on for about two or three seconds

I installed it on my Kospet Prime and it’s not working. I open the app, shows 2 tics: Wakeup screen and Weatherupdate. Both enabled. Press Start Service and that’s all I can do. Leave the app. Wake on turn is OFF (system). Wait a bit, turn my wrist, nothing happens, though I made many intents. I am on System Launcher.

You must turn off “battery saver” or turn off this single app from battery saver…

I turn off it also from “battery optimization”

Thank you, i was looking for this!

Thanks a lot. I really appreciate all the posts. Unfortunately, I haven’t been able to make it work😫

Since the weather is updated regularly, I suspect that “unrestrictiv data usage” must also be activated for this app.

Sorry Gintonic, already done… I am puzzled.

You can check a few things to find out the problem:

  1. Settings->Background cleaner->Battery Saver should be OFF
  2. Settings->WeatherOnRaise->Data Usage->Enable usage of cellular data should be ON (it is by default)
  3. If above two steps do not work, ensure that the package ‘com.android.watchweather’ is installed on your watch. You can get the list of packages on your watch by using ‘adb’ command.

This app is already tested on Android 7 watches. Ideally, it should work on Android 10 watches as well.

Are you using prime or prime 2

Thank you very much. I have checked all of those aspects and they are OK. The package is present. One of the things that I am not clear about, is that opening the app, it always show “Start Service”, I press on it and that is all I can do. So, I return to the watch face, get back to the app, open it and it is again as if I never started the service! So, I press Start Service again and so on, a never ending situation…

It is Prime Andy. Thanks a lot for your help

This may happen for a few reasons. One of them is Battery saver is ON. But even when the memory load is high.
Can you clean all the tasks and try again?

Thanks Salwan. I did something different. I put the round format in the restart menu and now, though I have the wake on raise option off, the screen
Wakes up, which I assume is the Weatheronraise program. Now I have to wait until the weather changes to be sure it’s working!!! Everybody have been very kind!

And now the app appears to be enabled on opening it, which did’t occur in the square format, as shown on the image

Bravo!!! It,s working!!! At last the app is fully operative.
The weather (temperature) was updated from 19 to 22 degrees.
So, conditions are the following:

  • Battery saver: Off
  • Screen on raising: Off
  • Format (in restart screen): Round
  • App settings: Unrestricted data access

I feel happy and grateful to all who contributed to my satisfaction!!! HURRA!!!

2 Likes

Thank you so much for this app. It is working on Lemfo14.

1 Like

Thanks so much for making this app it makes my Prime 2 what i wanted it to be

But (there is always something) is there any way of having the service run automatically at startup ?

Thanks

1 Like

hello, when I turn off the clock and turn it on again I have to open the application and hit star services, is there any way for it to stay permanently open even if you turn off the phone?

My friend, thank you, your app is so good and useful.

Is it posible to update it to work on new Lem12Pro firmware? Your app now crashes!

Thank you, let’s stay in touch.

I do not have a watch to try app on this firmware.
But you can try below things:

  1. Ensure Battery saver is off for this app. You can see that whether this firmware allows apps to run in the background. I believe it must, settings may be different.
  2. Weather app “com.android.watchweather” must be installed on the watch. If it not installed already, you can find the .apk in the link.
3 Likes