Unstable Bluetooth Watch Droid

Hi, I’m an owner of Zeblaze Thor Pro (updated to the latest version 20191215), currently I don’t use WiiWatch as a bluetooth connection with my smartphone (Samsung S8 root) but I use Watch Droid because I can respond to notifications and calls directly on the phone. smartwatch and I like this a lot. A problem arises however, the bluetooth connection is always disconnected and to maintain a stable connection I am forced to keep access even the wi-fi without being hooked to any network, so the smartwatch can stay connected to the smartphone without problems but also consuming a lot of battery . How can I resolve without having to activate wi-fi every time?
Thanks a lot to everyone

Goto settings - more - Backround Cleaner and disable watchdroid.

The smartphone already has all the background permissions and battery optimization forced to work best, in the smartwatch I have not found any of these settings to force.

It’s 7.1.1, so please goto settings - more - Backround Cleaner - Battery saver. Tap on it. Then a list of your apps will open. Disable watch droid.

1 Like

No, the smartwatch is 5.1 I don’t have the ability to access background options

Ah ok. I’ll have a look in a few hours.

1 Like

@Nico.222 have you read @MoAn 's post regarding watch droid, BT and thor pro?
I got used to not having it working properly and ended up using it mostly as stand alone.

wiiwatch seem to be the best way to have prolonged BT connection to the watch with thor pro, but it’s not as nice as droid watch feature wise.


Update for those who will open this topic:
I have tried different versions of Watch Droid and in my opinion the best is the 9.1 because from the next version the notifications of the calls don’t arrive anymore, something quite important and useful for me. In the smartphone the battery saving settings of the Watch Droid app are disabled. Also to have a reliable connection you need to keep the bluetooth and wifi on your smartwatch otherwise without the wifi you will get discontinuous discontinuities so increasing the battery consumption even more, the smartwatch will consume less by getting a stable fixed connection even if turned on bluetooth and wifi keeping bluetooth turned on but with continuous disconnections.
Some suggestions also found on this forum regarding the saving of the smartwatch battery are:

  • google services deactivated
  • deactivate the notification of music notifications from the smartphone, keeping only Watch Droid notifications
  • minimum brightness
  • display auto switch on function disabled
1 Like

Do it with wake lock app. Make the watch wake for unlimited time and display off. This will make the connection stable.